package/refresh should clean all packages before refreshing their patches
authorFelix Fietkau <nbd@openwrt.org>
Mon, 4 Jun 2007 11:20:03 +0000 (11:20 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 4 Jun 2007 11:20:03 +0000 (11:20 +0000)
SVN-Revision: 7489

package/Makefile

index 94241dbc3d860c5d875c22ea47789377cf1f7753..d6af3f28f79b20ce33c6410608fedaa633638171 100644 (file)
@@ -34,6 +34,9 @@ endif
 
 %-refresh %-update:
        -$(MAKE) -C $* $(patsubst $*-%,%,$@)
+       
+%-autorefresh:
+       -$(MAKE) -C $* clean refresh QUILT=1
 
 
 # .IGNORE: $(COMPILE_PACKAGES) 
@@ -46,9 +49,7 @@ clean: $(patsubst %,%-clean,$(package-) $(package-y) $(package-m))
 prereq: $(PREREQ_PACKAGES)
 download: $(DOWNLOAD_PACKAGES)
 compile: $(COMPILE_PACKAGES)
-ifneq ($(QUILT),)
-  refresh: $(patsubst %,%-refresh,$(package-y) $(package-m) $(package-))
-endif
+refresh: $(patsubst %,%-autorefresh,$(package-y) $(package-m) $(package-))
 
 install-targets: $(INSTALL_PACKAGES)
 install: