curl: bump to 7.55.1
authorStijn Tintel <stijn@linux-ipv6.be>
Mon, 25 Sep 2017 03:00:51 +0000 (06:00 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Mon, 25 Sep 2017 04:42:34 +0000 (07:42 +0300)
Update 200-no_docs_tests.patch.
Refresh patches.

Fixes the following CVEs:
- CVE-2017-1000099
- CVE-2017-1000100
- CVE-2017-1000101

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
package/network/utils/curl/Makefile
package/network/utils/curl/patches/200-no_docs_tests.patch
package/network/utils/curl/patches/310-mbedtls-disable-runtime-version-check.patch

index 9a59a66a8e700bef322f4cc38e623271274bce54..330d8d518c0f529ef4cf00c895499f869ef7fbf3 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.54.1
+PKG_VERSION:=7.55.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
        http://curl.mirror.anstey.ca/ \
        http://curl.askapache.com/download/ \
        https://curl.haxx.se/download/
-PKG_HASH:=fdfc4df2d001ee0c44ec071186e770046249263c491fcae48df0e1a3ca8f25a0
+PKG_HASH:=e5b1a92ed3b0c11f149886458fa063419500819f1610c020d62f25b8e4b16cfb
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
index f5a158bf9c2ee76a21c90866b625708f66e67105..9ef4819d414ebb165d869f69e35beb26256ba928 100644 (file)
@@ -1,22 +1,22 @@
 --- a/Makefile.am
 +++ b/Makefile.am
-@@ -154,8 +154,8 @@
+@@ -155,7 +155,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
  bin_SCRIPTS = curl-config
  
--SUBDIRS = lib docs src include
--DIST_SUBDIRS = $(SUBDIRS) tests packages scripts
-+SUBDIRS = lib src include
-+DIST_SUBDIRS = $(SUBDIRS) packages
+ SUBDIRS = lib src
+-DIST_SUBDIRS = $(SUBDIRS) tests packages scripts include docs
++DIST_SUBDIRS = $(SUBDIRS) packages include
  
  pkgconfigdir = $(libdir)/pkgconfig
  pkgconfig_DATA = libcurl.pc
-@@ -275,7 +275,7 @@
+@@ -275,8 +275,8 @@ cygwinbin:
  # We extend the standard install with a custom hook:
  install-data-hook:
        cd include && $(MAKE) install
 -      cd docs && $(MAKE) install
-+#     cd docs && $(MAKE) install
+-      cd docs/libcurl && $(MAKE) install
++      #cd docs && $(MAKE) install
++      #cd docs/libcurl && $(MAKE) install
  
  # We extend the standard uninstall with a custom hook:
  uninstall-hook:
index ef9c4b807064bc9fc9bf26cf3f917b4e6d7e62ee..52b017c9bf4eca7d08d2acf06ced2ca6ade3178f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/lib/vtls/mbedtls.c
 +++ b/lib/vtls/mbedtls.c
-@@ -796,7 +796,7 @@
+@@ -796,7 +796,7 @@ void Curl_mbedtls_session_free(void *ptr
  
  size_t Curl_mbedtls_version(char *buffer, size_t size)
  {