iproute2: remove libutil from InstallDev section
authorHans Dedecker <dedeckeh@gmail.com>
Thu, 9 Aug 2018 15:42:35 +0000 (17:42 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Thu, 9 Aug 2018 15:48:03 +0000 (17:48 +0200)
Commit 4d961538f6 added libutil to the iproute2 InstallDev section
but lead to compile issues with packages picking up the wrong libutil
since libutil is quite a generic name ...
Further libutil is rather meant for internal usage in iproute2 than a
public API; therefore let's remove it from the InstallDev section together
with ll_map.h

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/utils/iproute2/Makefile

index 679c0c2a2bf48be35dedb19d0e86f644361663e1..800a23ee0ec4a7bfd4fc4733f2a116431b4feb24 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 PKG_VERSION:=4.17.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/net/iproute2
@@ -132,10 +132,9 @@ endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_BUILD_DIR)/include/{libgenl,libnetlink,ll_map}.h $(1)/usr/include/
+       $(CP) $(PKG_BUILD_DIR)/include/{libgenl,libnetlink}.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/lib/libnetlink.a $(1)/usr/lib/
-       $(CP) $(PKG_BUILD_DIR)/lib/libutil.a $(1)/usr/lib/
 endef
 
 define Package/ip-tiny/install