include: fix detection of installed feeds
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 6 Aug 2014 09:12:31 +0000 (09:12 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 6 Aug 2014 09:12:31 +0000 (09:12 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 42003

include/feeds.mk

index 17ce64f83a400fca8639f68476541c5e459b519f..97b14491f0d538024e17c7f77ac6782698c620db 100644 (file)
@@ -8,8 +8,9 @@
 -include $(TMP_DIR)/.packagefeeds
 
 FEEDS_AVAILABLE:=$(shell $(SCRIPT_DIR)/feeds list -n)
-FEEDS_INSTALLED:=$(patsubst %.index,%,$(notdir $(wildcard $(TOPDIR)/feeds/*.index)))
+FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
 FEEDS_ENABLED:=$(foreach feed,$(FEEDS_INSTALLED),$(if $(CONFIG_FEED_$(feed)),$(feed)))
+FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_INSTALLED))
 
 PKG_CONFIG_DEPENDS += \
        CONFIG_PER_FEED_REPO \