update to 2.6.25.15 and 2.6.26.2
authorGabor Juhos <juhosg@openwrt.org>
Thu, 7 Aug 2008 16:52:52 +0000 (16:52 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 7 Aug 2008 16:52:52 +0000 (16:52 +0000)
SVN-Revision: 12242

21 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/etrax/Makefile
target/linux/generic-2.6/patches-2.6.25/965-cdc_acm_unlock.patch
target/linux/generic-2.6/patches-2.6.26/402-ledtrig_netdev.patch
target/linux/generic-2.6/patches-2.6.26/801-usb_serial_endpoint_size.patch
target/linux/ifxmips/Makefile
target/linux/ixp4xx/Makefile
target/linux/magicbox/Makefile
target/linux/orion/Makefile
target/linux/ps3/Makefile
target/linux/uml/Makefile
target/linux/x86/Makefile

index d06e41944fa50dcda3824de09c5501bf6f5e413f..52eef9dfbc02dcfd6e1467eceda1d5f5b9ce35fa 100644 (file)
@@ -25,11 +25,11 @@ endif
 ifeq ($(LINUX_VERSION),2.6.24.7)
   LINUX_KERNEL_MD5SUM:=40a73780d51525d28d36dec852c680c4
 endif
-ifeq ($(LINUX_VERSION),2.6.25.12)
-  LINUX_KERNEL_MD5SUM:=7c413ecf94a84776aaec6ada5694318c
+ifeq ($(LINUX_VERSION),2.6.25.15)
+  LINUX_KERNEL_MD5SUM:=13ed94f02fc2a11615e3332e1cdf50e7
 endif
-ifeq ($(LINUX_VERSION),2.6.26)
-  LINUX_KERNEL_MD5SUM:=5169d01c405bc3f866c59338e217968c
+ifeq ($(LINUX_VERSION),2.6.26.2)
+  LINUX_KERNEL_MD5SUM:=82472622bd26bed0054790ec3e60ee00
 endif
 
 # disable the md5sum check for unknown kernel versions
index e97a80ad6981ca0dd3a42c8efed48ea194f86b52..f87f9eaf8073a1814f1f97f905e16c0f76892747 100644 (file)
@@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-#LINUX_VERSION:=2.6.25.12
-LINUX_VERSION:=2.6.26
+#LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.26.2
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
index a40dc59fcf1e04f6019a5ed5abf78ade4a81b575..f6da81212395dd56c7a3cc1023d339204290f20e 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 
index 962f98f53e6e02d93be6e1d29ba3b77e5747f36f..66b1efc24ddb4275c08adba125c77d25e4d1c084 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar71xx
 BOARDNAME:=Atheros AR71xx
 FEATURES:=squashfs tgz broken
 
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
 
 include $(INCLUDE_DIR)/target.mk
 
index 00514c7939fd864b216bf5ab63dcd9c60ae6647f..90d10088d569922eb886a47e954b7eecc89d17de 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=at91
 BOARDNAME:=Atmel AT91
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 
index fa292ac96b69bb16082764b6e9e4f9cdbaf8890d..1544f82164de654ab85880ef07ecad31cf38aaa7 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros 231x/5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
 
 include $(INCLUDE_DIR)/target.mk
 
index e0228c5347fc702bdc3b6200f10c2bf8792751c2..25f94fca0d468e3ebfbbf88e72a85fa9db0a3f50 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=au1000
 BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
 
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += yamonenv
index a9af238f7f53c128c6153ddac0f3feb87178f925..de38c6581a61449cb7dace896b5acd0cc70ee077 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 
index 246c59a2d9e78176d1b763766461c6cb2c4a99fb..3ec9bbb83f64c0b82f2d7d4945a04d682c22bfe6 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-switch kmod-diag
index e232b00b1e8179c8953d62214a3c300100c5061a..79d21f62469d7f598cd0cac94e2e2a08091d4a69 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
 FEATURES:=squashfs jffs2 broken usb atm
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 
index 85911fbf354c45f6d14535c18d26654d6cba13c5..a08d6b8925f9a46c9659a4d8bdd7999e894301f3 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=cris
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
 FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 
index 7107a93157ae7a4f6e81b56dd9d51a4660f5cdfa..c70181c617c2485e290568cb0cbf1c0d9c245352 100644 (file)
@@ -1,5 +1,5 @@
---- linux-2.6.25.12/drivers/usb/class/cdc-acm.c        2008-07-24 18:14:20.000000000 +0200
-+++ linux-2.6.25.12.new/drivers/usb/class/cdc-acm.c    2008-08-05 21:39:35.000000000 +0200
+--- a/drivers/usb/class/cdc-acm.c
++++ b/drivers/usb/class/cdc-acm.c
 @@ -531,8 +531,8 @@
        tasklet_schedule(&acm->urb_task);
  
index 1dcdad65838ebe4c94ae4188d7f1dddb1587d20c..8a564b2ec80897d94a1b4ba4332f258c398a7d2a 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.26/drivers/leds/Kconfig
-===================================================================
---- linux-2.6.26.orig/drivers/leds/Kconfig     2008-08-04 15:03:44.000000000 +0200
-+++ linux-2.6.26/drivers/leds/Kconfig  2008-08-04 15:04:18.000000000 +0200
+--- a/drivers/leds/Kconfig
++++ b/drivers/leds/Kconfig
 @@ -200,4 +200,11 @@
        tristate "LED Morse Trigger"
        depends on LEDS_TRIGGERS
@@ -14,10 +12,8 @@ Index: linux-2.6.26/drivers/leds/Kconfig
 +        If unsure, say Y.
 +
  endif # NEW_LEDS
-Index: linux-2.6.26/drivers/leds/Makefile
-===================================================================
---- linux-2.6.26.orig/drivers/leds/Makefile    2008-08-04 15:03:40.000000000 +0200
-+++ linux-2.6.26/drivers/leds/Makefile 2008-08-04 15:04:29.000000000 +0200
+--- a/drivers/leds/Makefile
++++ b/drivers/leds/Makefile
 @@ -29,3 +29,4 @@
  obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT)  += ledtrig-heartbeat.o
  obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
index e856dc120a6da2fdfb006591afda605635ca8962..f1bd446bd59f903e2808c0f2b18cba3a48bc6a40 100644 (file)
@@ -8,7 +8,7 @@
  static int debug;
  static struct usb_serial *serial_table[SERIAL_TTY_MINORS];    /* initially all NULL */
  static DEFINE_MUTEX(table_lock);
-@@ -812,7 +813,7 @@
+@@ -815,7 +816,7 @@
                        dev_err(&interface->dev, "No free urbs available\n");
                        goto probe_error;
                }
@@ -17,7 +17,7 @@
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc (buffer_size, GFP_KERNEL);
-@@ -1226,3 +1227,5 @@
+@@ -1229,3 +1230,5 @@
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
index 04c620cc88cd1bedbe5bd0fb06b3178380ad8ab6..060782bbd33844cf2866dd58311cf7b5cd61dc2f 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES:=uboot-ifxmips
index cdfc4cb212f95abe1fcd5cd0f2398587fcd87590..897a2fac2ad263e33c005253e63cfbd8f6cec2a2 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
 
 include $(INCLUDE_DIR)/target.mk
 
index a804184d1aa86237c9751c35611bac3dfd531981..fcdd285a3f4ffd20715bffd441de6340b091959c 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=magicbox
 BOARDNAME:=Magicbox
 FEATURES:=squashfs pci
 
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
 LINUX_KARCH:=ppc
 
 include $(INCLUDE_DIR)/target.mk
index d5b8ba382c71ae5d5aa449bf66b32ac42b2d257c..c9474379f829749c108299339b9d80639926939c 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=orion
 BOARDNAME:=Marvell Orion
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
 
 include $(INCLUDE_DIR)/target.mk
 
index 0fe48835d3b40d701568599f8bd3e5d24f1021a0..a9e69a806b250806061597218763d7a9dc5aa289 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=powerpc
 BOARD:=ps3
 BOARDNAME:=Sony PS3 Game Console
 
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 KERNEL_CC:=
 
index f4298f55702671cc57b643c8a4e4a114c9160546..3dd9a986ab4d86ef6a5d2c887433884f82a7ce7d 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext2
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
-LINUX_VERSION:=2.6.26
+LINUX_VERSION:=2.6.26.2
 
 include $(INCLUDE_DIR)/target.mk
 
index 4d11d7fd907d9339b6de159a678e9b8223b47f1e..2d29198984bf853441735cf1d0fb5229a92717c7 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2 vdi
 SUBTARGETS=generic
 
-LINUX_VERSION:=2.6.25.12
+LINUX_VERSION:=2.6.25.15
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci