Lock copying of directory trees to the staging dir with the "staging-dir" lock. This...
authorMichael Büsch <mb@bu3sch.de>
Thu, 4 Nov 2010 12:28:55 +0000 (12:28 +0000)
committerMichael Büsch <mb@bu3sch.de>
Thu, 4 Nov 2010 12:28:55 +0000 (12:28 +0000)
SVN-Revision: 23857

include/package.mk

index 2d3a5d09668c3003ec6cd4873c87a1fa52967f43..712b793d0d63258853f88794d3294ddd0c2556e5 100644 (file)
@@ -132,8 +132,10 @@ define Build/DefaultTargets
                $(call $(hook),$(TMP_DIR)/stage-$(PKG_NAME),$(TMP_DIR)/stage-$(PKG_NAME)/host)$(sep)\
        )
        if [ -d $(TMP_DIR)/stage-$(PKG_NAME) ]; then \
-               (cd $(TMP_DIR)/stage-$(PKG_NAME); find ./ > $(STAGING_DIR)/packages/$(STAGING_FILES_LIST)); \
-               $(CP) $(TMP_DIR)/stage-$(PKG_NAME)/* $(STAGING_DIR)/; \
+               $(call locked, \
+                       (cd $(TMP_DIR)/stage-$(PKG_NAME); find ./ > $(STAGING_DIR)/packages/$(STAGING_FILES_LIST)); \
+                       $(CP) $(TMP_DIR)/stage-$(PKG_NAME)/* $(STAGING_DIR)/; \
+               ,staging-dir); \
        fi
        rm -rf $(TMP_DIR)/stage-$(PKG_NAME)
        touch $$@