netfilter: remove nf_tproxy_core references
authorMathias Kresin <dev@kresin.me>
Tue, 11 Oct 2016 06:55:41 +0000 (08:55 +0200)
committerMathias Kresin <dev@kresin.me>
Tue, 11 Oct 2016 07:03:12 +0000 (09:03 +0200)
nf_tproxy_core was removed during 3.12 development with kernel commit
fd158d79d33d3c8b693e3e2d8c0e3068d529c2dc. The code was moved
to xt_TPROXY.c.

Fixes FS#212

Signed-off-by: Mathias Kresin <dev@kresin.me>
package/kernel/linux/modules/netfilter.mk

index f72d0c9736f514469f3a9ca6b2b001d86b0314ee..c21f58d79b73d571c06aebdf21ced30793b47527 100644 (file)
@@ -457,12 +457,11 @@ define KernelPackage/ipt-tproxy
   TITLE:=Transparent proxying support
   DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-ip6tables
   KCONFIG:= \
-       CONFIG_NETFILTER_TPROXY \
        CONFIG_NETFILTER_XT_MATCH_SOCKET \
        CONFIG_NETFILTER_XT_TARGET_TPROXY
   FILES:= \
        $(foreach mod,$(IPT_TPROXY-m),$(LINUX_DIR)/net/$(mod).ko)
-  AUTOLOAD:=$(call AutoProbe,$(notdir nf_tproxy_core $(IPT_TPROXY-m)))
+  AUTOLOAD:=$(call AutoProbe,$(notdir $(IPT_TPROXY-m)))
   $(call AddDepends/ipt)
 endef