add prereq check for case-sensitive filesystem
authorFelix Fietkau <nbd@openwrt.org>
Sat, 14 Oct 2006 11:23:23 +0000 (11:23 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 14 Oct 2006 11:23:23 +0000 (11:23 +0000)
SVN-Revision: 5073

include/prereq-build.mk

index 486f573f83981d27a7a081506125ff34aa906673..10bc68ae158585f6a0c54dda6d42c43622378a7e 100644 (file)
@@ -30,6 +30,16 @@ $(eval $(call Require,working-make, \
        Please install GNU make v3.81 or later. (This version has bugs) \
 ))
 
+define Require/case-sensitive-fs
+       rm -f $(TMP_DIR)/test.*
+       touch $(TMP_DIR)/test.fs
+       [ \! -f $(TMP_DIR)/test.FS ]
+endef
+
+$(eval $(call Require,case-sensitive-fs, \
+       OpenWrt can only be built on a case-sensitive filesystem \
+))
+
 define Require/working-gcc
        echo 'int main(int argc, char **argv) { return 0; }' | \
                gcc -x c -o $(TMP_DIR)/a.out -