hostapd: fix eglibc 2.15 support
authorFelix Fietkau <nbd@openwrt.org>
Sun, 27 Apr 2014 18:30:50 +0000 (18:30 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 27 Apr 2014 18:30:50 +0000 (18:30 +0000)
This patch fixes compilation failure for hostapd when using eglibc 2.15.

Signed-off-by: Zachery Stoddard <zacherystoddard@gmail.com>
SVN-Revision: 40575

package/network/services/hostapd/Makefile

index 2e8eae2069ebf6427281d2ac96859668f312c477..80e00823fedc7513db18af3935a7b822276f5bdc 100644 (file)
@@ -88,6 +88,7 @@ endif
 
 ifdef CONFIG_USE_EGLIBC
   TARGET_LDFLAGS += -lrt
+  TARGET_LDFLAGS_C += -lrt
 endif
 
 DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny @(!TARGET_avr32||BROKEN)
@@ -267,7 +268,7 @@ define Build/RunMake
                $(TARGET_CONFIGURE_OPTS) \
                $(DRIVER_MAKEOPTS) \
                LIBS="$(TARGET_LDFLAGS)" \
-               LIBS_c="" \
+               LIBS_c="$(TARGET_LDFLAGS_C)" \
                BCHECK= \
                $(2)
 endef