kernel: bump 4.9 to 4.9.133
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 15 Oct 2018 09:18:54 +0000 (11:18 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 16 Oct 2018 08:08:54 +0000 (10:08 +0200)
Refreshed all patches.

Compile-tested on: ar71xx, layerscape
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.9/950-0060-config-Enable-CONFIG_MEMCG-but-leave-it-disabled-due.patch
target/linux/generic/hack-4.9/902-debloat_proc.patch

index 21f7510f2c104fba90ec898eccf356b3173a943a..f874160742641c00cf443e3badee53f8cc3baa0d 100644 (file)
@@ -3,11 +3,11 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .124
-LINUX_VERSION-4.9 = .132
+LINUX_VERSION-4.9 = .133
 LINUX_VERSION-4.14 = .75
 
 LINUX_KERNEL_HASH-3.18.124 = 25d2a5abd627534a1e51d028890c184aad8e628c345c5fe0cc0f9d7c31b7a5a3
-LINUX_KERNEL_HASH-4.9.132 = 67e66ae14595b3c93f228c417463e5436b9d64f5e9dfd3b92b7e24714d1ee5d3
+LINUX_KERNEL_HASH-4.9.133 = 53730fc025ba330a6f4908a6a1e4cb86d821000c84167721680ccf1b37b26563
 LINUX_KERNEL_HASH-4.14.75 = 5093d7230b8f1c553450ca6c1ccd20a46a055d9277a7e161039a8642b3398120
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 016d9cd99eb170c797997bfddffd79c70f829dbc..5dc823336d55254205e3ec8ffcd231d12b7fd114 100644 (file)
@@ -10,7 +10,7 @@ Subject: [PATCH] config: Enable CONFIG_MEMCG, but leave it disabled (due to
 
 --- a/kernel/cgroup.c
 +++ b/kernel/cgroup.c
-@@ -5632,7 +5632,7 @@ int __init cgroup_init_early(void)
+@@ -5636,7 +5636,7 @@ int __init cgroup_init_early(void)
        return 0;
  }
  
@@ -19,7 +19,7 @@ Subject: [PATCH] config: Enable CONFIG_MEMCG, but leave it disabled (due to
  
  /**
   * cgroup_init - cgroup initialization
-@@ -6173,6 +6173,28 @@ static int __init cgroup_no_v1(char *str
+@@ -6177,6 +6177,28 @@ static int __init cgroup_no_v1(char *str
  }
  __setup("cgroup_no_v1=", cgroup_no_v1);
  
index cab7276d290baab893a756b655c523a336fde7f6..cff61680835643afa14a2851fc13d13a38745288 100644 (file)
@@ -243,7 +243,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  }
 --- a/mm/vmstat.c
 +++ b/mm/vmstat.c
-@@ -1796,10 +1796,12 @@ static int __init setup_vmstat(void)
+@@ -1799,10 +1799,12 @@ static int __init setup_vmstat(void)
        cpu_notifier_register_done();
  #endif
  #ifdef CONFIG_PROC_FS