netifd: dhcp: install host route to gateway (#19182)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 15 Mar 2015 14:48:18 +0000 (14:48 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 15 Mar 2015 14:48:18 +0000 (14:48 +0000)
Certain DHCP servers push a gateway outside of the assigned interface subnet,
to support those situations install a host route towards the gateway.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44789

package/network/config/netifd/Makefile
package/network/config/netifd/files/lib/netifd/dhcp.script

index 81af3a72e579ecea996b4e7f556d7c5c78d66a8f..d1891902d00144c7d8d86e3db568b13f61d0eed2 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_VERSION:=2015-03-06
+PKG_VERSION:=2015-03-15
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
index 288ab18d0070bc721c5399b1200da096d122191e..a3219a0701adf40e79d2fe6143a56540014b2b25 100755 (executable)
@@ -19,6 +19,7 @@ setup_interface () {
        # TODO: apply $broadcast
 
        for i in $router; do
+               proto_add_ipv4_route "$i" 32 "" "$ip"
                proto_add_ipv4_route 0.0.0.0 0 "$i" "$ip"
        done