ramips: fix wrong blocksizes
authorMathias Kresin <dev@kresin.me>
Wed, 14 Sep 2016 17:11:19 +0000 (19:11 +0200)
committerMathias Kresin <dev@kresin.me>
Thu, 15 Sep 2016 07:53:37 +0000 (09:53 +0200)
The D-Link DIR-860L B1 has a flash chip which doesn't support
4K sectors. Since the DIR-860L B1 was the only mt7621 board which had
the 4k blocksize set, the 4K sector support is removed from the kernel
config.

I've checked the flash chips of all boards having set a 4K blocksize
again. This time I searched harder to finding bootlogs instead of
relying on wikis articles and/or the device tree source file.

The Planex MZK-DP150N has an en25q32b instead of the mentioned one in
the dts. Albeit the en25q32b supports 4K sectors, 4K support is not
enabled in the driver. Change the blocksize for this board back to 64K.

Reported-by: Russell Senior <russell@personaltelco.net>
Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ramips/image/mt7621.mk
target/linux/ramips/image/rt305x.mk
target/linux/ramips/mt7621/config-4.4

index ceed8ab4f1799aadafea6d4dbfaac8e60b4d220f..0c14d515d0df334b5fe4727930e0ea5fa791e4a2 100644 (file)
@@ -57,7 +57,7 @@ TARGET_DEVICES += wsr-1166
 
 define Device/dir-860l-b1
   DTS := DIR-860L-B1
 
 define Device/dir-860l-b1
   DTS := DIR-860L-B1
-  BLOCKSIZE := 4k
+  BLOCKSIZE := 64k
   IMAGES += factory.bin
   KERNEL := kernel-bin | patch-dtb | relocate-kernel | lzma | uImage lzma
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
   IMAGES += factory.bin
   KERNEL := kernel-bin | patch-dtb | relocate-kernel | lzma | uImage lzma
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
index 13193ae7961fa67ddaa67f4f5ade71e21d89a99b..be21ac47b9ea2d9e464ffaabafb8b25bb2074427 100644 (file)
@@ -432,7 +432,7 @@ TARGET_DEVICES += wcr150gn
 
 define Device/mzk-dp150n
   DTS := MZK-DP150N
 
 define Device/mzk-dp150n
   DTS := MZK-DP150N
-  BLOCKSIZE := 4k
+  BLOCKSIZE := 64k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_TITLE := Planex MZK-DP150N
   DEVICE_PACKAGES := kmod-spi-dev
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_TITLE := Planex MZK-DP150N
   DEVICE_PACKAGES := kmod-spi-dev
index b391005a31cfedbb9bd37029e44314da870d4525..9132d894df53950947d7c9377f1356ad8c640634 100644 (file)
@@ -159,7 +159,6 @@ CONFIG_MTD_NAND=y
 CONFIG_MTD_NAND_ECC=y
 CONFIG_MTD_PHYSMAP=y
 CONFIG_MTD_SPI_NOR=y
 CONFIG_MTD_NAND_ECC=y
 CONFIG_MTD_PHYSMAP=y
 CONFIG_MTD_SPI_NOR=y
-CONFIG_MTD_SPI_NOR_USE_4K_SECTORS=y
 CONFIG_MTD_SPLIT_FIRMWARE=y
 CONFIG_MTD_SPLIT_SEAMA_FW=y
 CONFIG_MTD_SPLIT_TRX_FW=y
 CONFIG_MTD_SPLIT_FIRMWARE=y
 CONFIG_MTD_SPLIT_SEAMA_FW=y
 CONFIG_MTD_SPLIT_TRX_FW=y