gemini: fix parallel build
authorMathias Kresin <dev@kresin.me>
Wed, 16 Jan 2019 20:57:53 +0000 (21:57 +0100)
committerMathias Kresin <dev@kresin.me>
Sat, 26 Jan 2019 14:23:36 +0000 (15:23 +0100)
Due to the missing PROFILES all images are build, regardless of the
selected (or currently processed in case of a multi profile build).

Because of the race condition builds with eight parallel jobs fail,
which can be seen on the build bots as well.

Add the PROFILES variable for now, till the root cause is identified.

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/gemini/image/Makefile

index 566ac96122477fcf100f07eb5944912d77de3266..5f987875d318e71db593c33b5fa8db60f41a9ac5 100644 (file)
@@ -71,6 +71,7 @@ endef
 
 # All DTB files are prefixed with "gemini-"
 define Device/Default
+       PROFILES := Default
        DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
        KERNEL_NAME := zImage