kernel: make kmod-pcnet32 depend on kmod-mii
authorFlorian Fainelli <florian@openwrt.org>
Fri, 25 Oct 2013 01:47:45 +0000 (01:47 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 25 Oct 2013 01:47:45 +0000 (01:47 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 38531

package/kernel/linux/modules/netdevices.mk

index 6cac27a02971721c5e165655cf10f1c3123e7c2b..0bebe28ee32c311b0d3b4b8e9ac4e1467b15768b 100644 (file)
@@ -484,7 +484,7 @@ $(eval $(call KernelPackage,3c59x))
 define KernelPackage/pcnet32
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=AMD PCnet32 PCI support
-  DEPENDS:=@(PCI_SUPPORT||TARGET_malta)
+  DEPENDS:=@(PCI_SUPPORT||TARGET_malta) +kmod-mii
   KCONFIG:=CONFIG_PCNET32
   FILES:=$(LINUX_DIR)/drivers/net/ethernet/amd/pcnet32.ko
   AUTOLOAD:=$(call AutoProbe,pcnet32)