strip third arg (dir name) to Build/Configure/Default macro
authorNicolas Thill <nico@openwrt.org>
Sun, 22 Oct 2006 21:15:55 +0000 (21:15 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 22 Oct 2006 21:15:55 +0000 (21:15 +0000)
SVN-Revision: 5261

include/package.mk

index 01781c71c7dd79f301c34bf99f78b44ad3d5ee80..5636b0b6a1d8c226a1977359ac784b7b35257029 100644 (file)
@@ -290,7 +290,7 @@ define Build/Prepare
 endef
 
 define Build/Configure/Default
-       (cd $(PKG_BUILD_DIR)/$(3); \
+       (cd $(PKG_BUILD_DIR)/$(strip $(3)); \
        if [ -x configure ]; then \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \