busybox: keep syslog.conf during sysupgrade
authorVal Kulkov <val.kulkov@gmail.com>
Thu, 20 Dec 2018 20:04:43 +0000 (15:04 -0500)
committerJo-Philipp Wich <jo@mein.io>
Wed, 30 Jan 2019 11:30:03 +0000 (12:30 +0100)
If a user finds that logd is too barebone for their needs and wishes
to have more control over syslog, the user presently has an option
to enable CONFIG_BUSYBOX_CONFIG_FEATURE_SYSLOG and configure syslog
with settings in /etc/syslog.conf.

Presently /etc/syslog.conf silently disappears on sysupgrade. This
patch prevents such unwanted behaviour if busybox syslog is enabled
via CONFIG_BUSYBOX_CONFIG_FEATURE_SYSLOG.

Signed-off-by: Val Kulkov <val.kulkov@gmail.com>
package/utils/busybox/Makefile

index 0eaec1993860910fca36d51b143843e871f15398..dbc5dee62cb4b5142821e16d813bd5ae3a4d839e 100644 (file)
@@ -73,6 +73,12 @@ define Package/busybox/config
        source "$(SOURCE)/Config.in"
 endef
 
+ifdef CONFIG_BUSYBOX_CONFIG_FEATURE_SYSLOG
+define Package/busybox/conffiles
+/etc/syslog.conf
+endef
+endif
+
 # don't create a version string containing the actual timestamp
 export KCONFIG_NOTIMESTAMP=1