lua: add lua.hpp to InstallDev
authorJames Taylor <james@jtaylor.id.au>
Wed, 5 Jun 2019 12:22:15 +0000 (22:22 +1000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 18 Aug 2019 12:06:24 +0000 (14:06 +0200)
This is necessary to build PowerDNS authoritative and recursor against
OpenWRT, and may avoid packages depending on lua/host unnecessarily.

Signed-off-by: James Taylor <james@jtaylor.id.au>
package/utils/lua/Makefile

index c911c6a9137da6adf09b5c915b2fccb08df003dc..a2870448bda73c61042042146f7da5835839af64 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lua
 PKG_VERSION:=5.1.5
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
@@ -138,6 +138,7 @@ endef
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/lua{,lib,conf}.h $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/lua.hpp $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/lauxlib.h $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/lnum_config.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib