mvebu: remove unnecessary code building dtbs
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Sat, 11 May 2019 17:37:28 +0000 (19:37 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 11 May 2019 21:11:04 +0000 (23:11 +0200)
Even if dts is not included in upstream Makefile, it is built anyway by
recipe specified in include/image.mk. Also remove Build/dtb, it's not
used since 3f72f3a ("mvebu: clearfog: include DTB for all variants in
image").

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
target/linux/mvebu/image/Makefile
target/linux/mvebu/patches-4.14/105-build_new_dtbs.patch [deleted file]

index 88790777d9ccc7f9d5faf6624e793faffec09438..72b14e344b389357b97769cccd834aac564ab4e2 100644 (file)
@@ -15,10 +15,6 @@ KERNEL_LOADADDR := 0x00008000
 
 SIGNATURE:=$(shell printf "%.8s" $(SOURCE_DATE_EPOCH))
 
-define Build/dtb
-       $(call Image/BuildDTB,$(DTS_DIR)/$(DEVICE_DTS).dts,$@.dtb)
-endef
-
 define Build/boot-scr
        rm -f $@-boot.scr
        sed -e 's#@ROOT@#$(SIGNATURE)#g' \
@@ -29,7 +25,7 @@ endef
 define Build/boot-img
        rm -f $@.boot
        mkfs.fat -C $@.boot $$(( $(CONFIG_TARGET_KERNEL_PARTSIZE) * 1024 ))
-       $(foreach dts,$(DEVICE_DTS), mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::$(dts).dtb;)
+       $(foreach dts,$(DEVICE_DTS), mcopy -i $@.boot $(KDIR)/image-$(dts).dtb ::$(dts).dtb;)
        mcopy -i $@.boot $(IMAGE_KERNEL) ::$(KERNEL_NAME)
        -mcopy -i $@.boot $@-boot.scr ::boot.scr
 endef
@@ -37,7 +33,7 @@ endef
 define Build/boot-img-ext4
        rm -fR $@.boot
        mkdir -p $@.boot
-       $(foreach dts,$(DEVICE_DTS), $(CP) $(DTS_DIR)/$(dts).dtb $@.boot;)
+       $(foreach dts,$(DEVICE_DTS), $(CP) $(KDIR)/image-$(dts).dtb $@.boot/$(dts).dtb;)
        $(CP) $(IMAGE_KERNEL) $@.boot/$(KERNEL_NAME)
        -$(CP) $@-boot.scr $@.boot/boot.scr
        make_ext4fs -J -l $(CONFIG_TARGET_KERNEL_PARTSIZE)M $@.bootimg $@.boot
@@ -70,7 +66,7 @@ define Build/omnia-medkit-initramfs
        rm -rf $(dir $(IMAGE_KERNEL))boot
        mkdir -p $(dir $(IMAGE_KERNEL))boot/boot/
        cp $(KDIR)/zImage-initramfs $(dir $(IMAGE_KERNEL))boot/boot/zImage
-       cp $(DTS_DIR)/$(DEVICE_DTS).dtb $(dir $(IMAGE_KERNEL))boot/boot/dtb
+       cp $(KDIR)/image-$(DEVICE_DTS).dtb $(dir $(IMAGE_KERNEL))boot/boot/dtb
        $(TAR) -rp --numeric-owner --owner=0 --group=0 --sort=name \
                $(if $(SOURCE_DATE_EPOCH),--mtime="@$(SOURCE_DATE_EPOCH)") \
                --file=$@ -C $(dir $(IMAGE_KERNEL))boot/ .
diff --git a/target/linux/mvebu/patches-4.14/105-build_new_dtbs.patch b/target/linux/mvebu/patches-4.14/105-build_new_dtbs.patch
deleted file mode 100644 (file)
index 92880b9..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -1027,6 +1027,7 @@ dtb-$(CONFIG_MACH_ARMADA_38X) += \
-       armada-385-linksys-cobra.dtb \
-       armada-385-linksys-rango.dtb \
-       armada-385-linksys-shelby.dtb \
-+      armada-385-linksys-venom.dtb \
-       armada-385-synology-ds116.dtb \
-       armada-385-turris-omnia.dtb \
-       armada-388-clearfog.dtb \