kernel: bump 4.19 to 4.19.86
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 25 Nov 2019 10:32:08 +0000 (11:32 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 29 Nov 2019 08:59:49 +0000 (09:59 +0100)
Refreshed all patches.

Altered patches:
- 950-0064-mfd-Add-Raspberry-Pi-Sense-HAT-core-driver.patch
- 0005-mtd-physmap_of-Move-custom-initialization.patch

Remove upstreamed:
- 0001-pinctrl-gemini-Mask-and-set-properly.patch
- 0002-pinctrl-gemini-Fix-up-TVC-clock-group.patch

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
17 files changed:
include/kernel-version.mk
target/linux/ath79/patches-4.19/910-unaligned_access_hacks.patch
target/linux/brcm2708/patches-4.19/950-0041-bcm2708-framebuffer-driver.patch
target/linux/brcm2708/patches-4.19/950-0064-mfd-Add-Raspberry-Pi-Sense-HAT-core-driver.patch
target/linux/cns3xxx/patches-4.19/070-i2c_support.patch
target/linux/cns3xxx/patches-4.19/210-dwc2_defaults.patch
target/linux/gemini/patches-4.19/0001-pinctrl-gemini-Mask-and-set-properly.patch [deleted file]
target/linux/gemini/patches-4.19/0002-pinctrl-gemini-Fix-up-TVC-clock-group.patch [deleted file]
target/linux/gemini/patches-4.19/0005-mtd-physmap_of-Move-custom-initialization.patch
target/linux/generic/backport-4.19/200-v5.2-usb-dwc2-Set-lpm-mode-parameters-depend-on-HW-configuration.patch
target/linux/generic/hack-4.19/661-use_fq_codel_by_default.patch
target/linux/generic/hack-4.19/662-remove_pfifo_fast.patch
target/linux/generic/pending-4.19/220-optimize_inlining.patch
target/linux/generic/pending-4.19/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/lantiq/patches-4.19/0022-MTD-m25p80-allow-loading-mtd-name-from-OF.patch
target/linux/lantiq/patches-4.19/0031-I2C-MIPS-lantiq-add-FALC-ON-i2c-bus-master.patch
target/linux/lantiq/patches-4.19/0050-USB-DWC2-make-the-lantiq-settings-match-vendor-drive.patch

index 90a548fa4be80f032010b4d35278179461c864db..d939b09fb5ad1a7b2d739566de5465e8cb0e08b6 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .202
 LINUX_VERSION-4.14 = .156
-LINUX_VERSION-4.19 = .85
+LINUX_VERSION-4.19 = .86
 
 LINUX_KERNEL_HASH-4.9.202 = 8108ec1cd10fc40821c84e9f087dba10b1767aad66596f4a36925faef55e4ebf
 LINUX_KERNEL_HASH-4.14.156 = f8889feb0cbd7df36ff35bd4c72c1e2010567621bfcb218fcfa501bc5c7787c0
-LINUX_KERNEL_HASH-4.19.85 = 7bf435970aeeafd46263f49730087a61c4858d8b8fc5a4002ceac971b45f4fb7
+LINUX_KERNEL_HASH-4.19.86 = bf2cbba319d43d1bd9e876ac0b55ab83118d1a1e61cce3c929d5371f7567bff6
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 43c4932f1f36730eb610aa2eaf3d035c8a9b11d5..ad7b12d650cc31d94cdf5da032c67023ee904e05 100644 (file)
        return neigh_create(&arp_tbl, pkey, dev);
 --- a/net/ipv4/tcp_output.c
 +++ b/net/ipv4/tcp_output.c
-@@ -461,48 +461,53 @@ static void tcp_options_write(__be32 *pt
+@@ -444,48 +444,53 @@ static void tcp_options_write(__be32 *pt
        u16 options = opts->options;    /* mungable copy */
  
        if (unlikely(OPTION_MD5 & options)) {
        }
  
        if (unlikely(opts->num_sack_blocks)) {
-@@ -510,16 +515,17 @@ static void tcp_options_write(__be32 *pt
+@@ -493,16 +498,17 @@ static void tcp_options_write(__be32 *pt
                        tp->duplicate_sack : tp->selective_acks;
                int this_sack;
  
                }
  
                tp->rx_opt.dsack = 0;
-@@ -532,13 +538,14 @@ static void tcp_options_write(__be32 *pt
+@@ -515,13 +521,14 @@ static void tcp_options_write(__be32 *pt
  
                if (foc->exp) {
                        len = TCPOLEN_EXP_FASTOPEN_BASE + foc->len;
  EXPORT_SYMBOL(xfrm_parse_spi);
 --- a/net/ipv4/tcp_input.c
 +++ b/net/ipv4/tcp_input.c
-@@ -3912,14 +3912,16 @@ static bool tcp_parse_aligned_timestamp(
+@@ -3891,14 +3891,16 @@ static bool tcp_parse_aligned_timestamp(
  {
        const __be32 *ptr = (const __be32 *)(th + 1);
  
index c019bc827144b1489636221410c50e115c83d3da..7135ff3fcff879601ae4875e1eaa116dcfa8a715 100644 (file)
@@ -93,7 +93,7 @@ Signed-off-by: James Hughes <james.hughes@raspberrypi.org>
 
 --- a/drivers/video/fbdev/Kconfig
 +++ b/drivers/video/fbdev/Kconfig
-@@ -236,6 +236,20 @@ config FB_TILEBLITTING
+@@ -242,6 +242,20 @@ config FB_TILEBLITTING
  comment "Frame buffer hardware drivers"
        depends on FB
  
index 00228d6434b8b425d97bf0ea688f9dedca055f0b..1a8ab6c44e82a3622738aadbd80b09250bdaafc0 100644 (file)
@@ -390,11 +390,10 @@ Subject: [PATCH 064/806] mfd: Add Raspberry Pi Sense HAT core driver
 +
 --- a/drivers/video/fbdev/Kconfig
 +++ b/drivers/video/fbdev/Kconfig
-@@ -2355,3 +2355,16 @@ config FB_SM712
-         This driver is also available as a module. The module will be
+@@ -2350,6 +2350,19 @@ config FB_SM712
          called sm712fb. If you want to compile it as a module, say M
          here and read <file:Documentation/kbuild/modules.txt>.
-+
 +config FB_RPISENSE
 +      tristate "Raspberry Pi Sense HAT framebuffer"
 +      depends on FB
@@ -407,6 +406,10 @@ Subject: [PATCH 064/806] mfd: Add Raspberry Pi Sense HAT core driver
 +
 +      help
 +        This is the framebuffer driver for the Raspberry Pi Sense HAT
++
+ source "drivers/video/fbdev/omap/Kconfig"
+ source "drivers/video/fbdev/omap2/Kconfig"
+ source "drivers/video/fbdev/mmp/Kconfig"
 --- a/drivers/video/fbdev/Makefile
 +++ b/drivers/video/fbdev/Makefile
 @@ -138,6 +138,7 @@ obj-$(CONFIG_FB_DA8XX)               += da8xx-fb.o
index 9bfb8444e6ad8516db869eeb448ae68ac394ed9e..95768f64a8acf81ac11687ef02fbb19cf9899b2b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -459,6 +459,18 @@ config I2C_CBUS_GPIO
+@@ -460,6 +460,18 @@ config I2C_CBUS_GPIO
          This driver can also be built as a module.  If so, the module
          will be called i2c-cbus-gpio.
  
index fcadd25a2a156e1272f21fcf9de5d5921601fd65..3efcc18854eee5b195390834524fde9cc3427d9a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/usb/dwc2/params.c
 +++ b/drivers/usb/dwc2/params.c
-@@ -151,6 +151,36 @@ static void dwc2_set_stm32f7_hsotg_param
+@@ -152,6 +152,36 @@ static void dwc2_set_stm32f7_hsotg_param
        p->host_perio_tx_fifo_size = 256;
  }
  
@@ -37,7 +37,7 @@
  const struct of_device_id dwc2_of_match_table[] = {
        { .compatible = "brcm,bcm2835-usb", .data = dwc2_set_bcm_params },
        { .compatible = "hisilicon,hi6220-usb", .data = dwc2_set_his_params  },
-@@ -819,17 +849,23 @@ int dwc2_get_hwparams(struct dwc2_hsotg
+@@ -820,17 +850,23 @@ int dwc2_get_hwparams(struct dwc2_hsotg
  
  int dwc2_init_params(struct dwc2_hsotg *hsotg)
  {
diff --git a/target/linux/gemini/patches-4.19/0001-pinctrl-gemini-Mask-and-set-properly.patch b/target/linux/gemini/patches-4.19/0001-pinctrl-gemini-Mask-and-set-properly.patch
deleted file mode 100644 (file)
index 3bf9341..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From f8ac3d3472a8dc99c8647a637611d146d88be8cb Mon Sep 17 00:00:00 2001
-From: Linus Walleij <linus.walleij@linaro.org>
-Date: Tue, 9 Oct 2018 10:09:14 +0200
-Subject: [PATCH 01/18] pinctrl: gemini: Mask and set properly
-
-The code was written under the assumption that the
-regmap_update_bits() would mask the bits in the mask and
-set the bits in the value.
-
-It missed the points that it will not set bits in the value
-unless these are also masked in the mask. Set value bits
-that are not in the mask will simply be ignored.
-
-Fixes: 06351d133dea ("pinctrl: add a Gemini SoC pin controller")
-Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
----
- drivers/pinctrl/pinctrl-gemini.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
---- a/drivers/pinctrl/pinctrl-gemini.c
-+++ b/drivers/pinctrl/pinctrl-gemini.c
-@@ -2184,7 +2184,8 @@ static int gemini_pmx_set_mux(struct pin
-                func->name, grp->name);
-       regmap_read(pmx->map, GLOBAL_MISC_CTRL, &before);
--      regmap_update_bits(pmx->map, GLOBAL_MISC_CTRL, grp->mask,
-+      regmap_update_bits(pmx->map, GLOBAL_MISC_CTRL,
-+                         grp->mask | grp->value,
-                          grp->value);
-       regmap_read(pmx->map, GLOBAL_MISC_CTRL, &after);
diff --git a/target/linux/gemini/patches-4.19/0002-pinctrl-gemini-Fix-up-TVC-clock-group.patch b/target/linux/gemini/patches-4.19/0002-pinctrl-gemini-Fix-up-TVC-clock-group.patch
deleted file mode 100644 (file)
index 64172ac..0000000
+++ /dev/null
@@ -1,141 +0,0 @@
-From ce81398dccb984855de606b75db25eddecdaa9e5 Mon Sep 17 00:00:00 2001
-From: Linus Walleij <linus.walleij@linaro.org>
-Date: Wed, 10 Oct 2018 20:25:39 +0200
-Subject: [PATCH 02/18] pinctrl: gemini: Fix up TVC clock group
-
-The previous fix made the TVC clock get muxed in on the
-D-Link DIR-685 instead of giving nagging warnings of this
-not working. Not good. We didn't want that, as it breaks
-video.
-
-Create a specific group for the TVC CLK, and break out
-a specific GPIO group for it on the SL3516 so we can use
-that line as GPIO if we don't need the TVC CLK.
-
-Fixes: d17f477c5bc6 ("pinctrl: gemini: Mask and set properly")
-Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
----
- drivers/pinctrl/pinctrl-gemini.c | 44 ++++++++++++++++++++++++++------
- 1 file changed, 36 insertions(+), 8 deletions(-)
-
---- a/drivers/pinctrl/pinctrl-gemini.c
-+++ b/drivers/pinctrl/pinctrl-gemini.c
-@@ -591,13 +591,16 @@ static const unsigned int tvc_3512_pins[
-       319, /* TVC_DATA[1] */
-       301, /* TVC_DATA[2] */
-       283, /* TVC_DATA[3] */
--      265, /* TVC_CLK */
-       320, /* TVC_DATA[4] */
-       302, /* TVC_DATA[5] */
-       284, /* TVC_DATA[6] */
-       266, /* TVC_DATA[7] */
- };
-+static const unsigned int tvc_clk_3512_pins[] = {
-+      265, /* TVC_CLK */
-+};
-+
- /* NAND flash pins */
- static const unsigned int nflash_3512_pins[] = {
-       199, 200, 201, 202, 216, 217, 218, 219, 220, 234, 235, 236, 237, 252,
-@@ -629,7 +632,7 @@ static const unsigned int pflash_3512_pi
- /* Serial flash pins CE0, CE1, DI, DO, CK */
- static const unsigned int sflash_3512_pins[] = { 230, 231, 232, 233, 211 };
--/* The GPIO0A (0) pin overlap with TVC and extended parallel flash */
-+/* The GPIO0A (0) pin overlap with TVC CLK and extended parallel flash */
- static const unsigned int gpio0a_3512_pins[] = { 265 };
- /* The GPIO0B (1-4) pins overlap with TVC and ICE */
-@@ -823,7 +826,13 @@ static const struct gemini_pin_group gem
-               .num_pins = ARRAY_SIZE(tvc_3512_pins),
-               /* Conflict with character LCD and ICE */
-               .mask = LCD_PADS_ENABLE,
--              .value = TVC_PADS_ENABLE | TVC_CLK_PAD_ENABLE,
-+              .value = TVC_PADS_ENABLE,
-+      },
-+      {
-+              .name = "tvcclkgrp",
-+              .pins = tvc_clk_3512_pins,
-+              .num_pins = ARRAY_SIZE(tvc_clk_3512_pins),
-+              .value = TVC_CLK_PAD_ENABLE,
-       },
-       /*
-        * The construction is done such that it is possible to use a serial
-@@ -860,8 +869,8 @@ static const struct gemini_pin_group gem
-               .name = "gpio0agrp",
-               .pins = gpio0a_3512_pins,
-               .num_pins = ARRAY_SIZE(gpio0a_3512_pins),
--              /* Conflict with TVC */
--              .mask = TVC_PADS_ENABLE,
-+              /* Conflict with TVC CLK */
-+              .mask = TVC_CLK_PAD_ENABLE,
-       },
-       {
-               .name = "gpio0bgrp",
-@@ -1531,13 +1540,16 @@ static const unsigned int tvc_3516_pins[
-       311, /* TVC_DATA[1] */
-       394, /* TVC_DATA[2] */
-       374, /* TVC_DATA[3] */
--      333, /* TVC_CLK */
-       354, /* TVC_DATA[4] */
-       395, /* TVC_DATA[5] */
-       312, /* TVC_DATA[6] */
-       334, /* TVC_DATA[7] */
- };
-+static const unsigned int tvc_clk_3516_pins[] = {
-+      333, /* TVC_CLK */
-+};
-+
- /* NAND flash pins */
- static const unsigned int nflash_3516_pins[] = {
-       243, 260, 261, 224, 280, 262, 281, 264, 300, 263, 282, 301, 320, 283,
-@@ -1570,7 +1582,7 @@ static const unsigned int pflash_3516_pi
- static const unsigned int sflash_3516_pins[] = { 296, 338, 295, 359, 339 };
- /* The GPIO0A (0-4) pins overlap with TVC and extended parallel flash */
--static const unsigned int gpio0a_3516_pins[] = { 333, 354, 395, 312, 334 };
-+static const unsigned int gpio0a_3516_pins[] = { 354, 395, 312, 334 };
- /* The GPIO0B (5-7) pins overlap with ICE */
- static const unsigned int gpio0b_3516_pins[] = { 375, 396, 376 };
-@@ -1602,6 +1614,9 @@ static const unsigned int gpio0j_3516_pi
- /* The GPIO0K (30,31) pins overlap with NAND flash */
- static const unsigned int gpio0k_3516_pins[] = { 275, 298 };
-+/* The GPIO0L (0) pins overlap with TVC_CLK */
-+static const unsigned int gpio0l_3516_pins[] = { 333 };
-+
- /* The GPIO1A (0-4) pins that overlap with IDE and parallel flash */
- static const unsigned int gpio1a_3516_pins[] = { 221, 200, 222, 201, 220 };
-@@ -1761,7 +1776,13 @@ static const struct gemini_pin_group gem
-               .num_pins = ARRAY_SIZE(tvc_3516_pins),
-               /* Conflict with character LCD */
-               .mask = LCD_PADS_ENABLE,
--              .value = TVC_PADS_ENABLE | TVC_CLK_PAD_ENABLE,
-+              .value = TVC_PADS_ENABLE,
-+      },
-+      {
-+              .name = "tvcclkgrp",
-+              .pins = tvc_clk_3516_pins,
-+              .num_pins = ARRAY_SIZE(tvc_clk_3516_pins),
-+              .value = TVC_CLK_PAD_ENABLE,
-       },
-       /*
-        * The construction is done such that it is possible to use a serial
-@@ -1873,6 +1894,13 @@ static const struct gemini_pin_group gem
-               .value = PFLASH_PADS_DISABLE | NAND_PADS_DISABLE,
-       },
-       {
-+              .name = "gpio0lgrp",
-+              .pins = gpio0l_3516_pins,
-+              .num_pins = ARRAY_SIZE(gpio0l_3516_pins),
-+              /* Conflict with TVE CLK */
-+              .mask = TVC_CLK_PAD_ENABLE,
-+      },
-+      {
-               .name = "gpio1agrp",
-               .pins = gpio1a_3516_pins,
-               .num_pins = ARRAY_SIZE(gpio1a_3516_pins),
index 5462844a790ca5c0139ffe60d079be5e390dff4c..1af8a0399523000e4cbb55286bb0bcd6e5f1dab8 100644 (file)
@@ -16,32 +16,22 @@ Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
 
 --- a/drivers/mtd/maps/physmap_of_core.c
 +++ b/drivers/mtd/maps/physmap_of_core.c
-@@ -239,13 +239,6 @@ static int of_flash_probe(struct platfor
+@@ -231,6 +231,9 @@ static int of_flash_probe(struct platfor
                else if (of_property_read_bool(dp, "little-endian"))
                        info->list[i].map.swap = CFI_LITTLE_ENDIAN;
  
--              err = of_flash_probe_gemini(dev, dp, &info->list[i].map);
--              if (err)
--                      goto err_out;
--              err = of_flash_probe_versatile(dev, dp, &info->list[i].map);
--              if (err)
--                      goto err_out;
--
-               err = -ENOMEM;
-               info->list[i].map.virt = ioremap(info->list[i].map.phys,
-                                                info->list[i].map.size);
-@@ -257,6 +250,14 @@ static int of_flash_probe(struct platfor
-               simple_map_init(&info->list[i].map);
-+              /* Variants can override map accessors */
-+              err = of_flash_probe_gemini(dev, dp, &info->list[i].map);
-+              if (err)
-+                      goto err_out;
-+              err = of_flash_probe_versatile(dev, dp, &info->list[i].map);
-+              if (err)
-+                      goto err_out;
++              simple_map_init(&info->list[i].map);
 +
++              /* Variants can override map accessors */
+               err = of_flash_probe_gemini(dev, dp, &info->list[i].map);
+               if (err)
+                       goto err_out;
+@@ -238,8 +241,6 @@ static int of_flash_probe(struct platfor
+               if (err)
+                       goto err_out;
+-              simple_map_init(&info->list[i].map);
+-
                /*
                 * On some platforms (e.g. MPC5200) a direct 1:1 mapping
                 * may cause problems with JFFS2 usage, as the local bus (LPB)
index b41bbf5395c1ff55ea4502cf2708bac794449495..ed4aadf2beb2888b3943fe1ce584131686890fcd 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
 
 --- a/drivers/usb/dwc2/params.c
 +++ b/drivers/usb/dwc2/params.c
-@@ -272,6 +272,23 @@ static void dwc2_set_param_power_down(st
+@@ -273,6 +273,23 @@ static void dwc2_set_param_power_down(st
        hsotg->params.power_down = val;
  }
  
@@ -41,7 +41,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
  /**
   * dwc2_set_default_params() - Set all core parameters to their
   * auto-detected default values.
-@@ -290,6 +307,7 @@ static void dwc2_set_default_params(stru
+@@ -291,6 +308,7 @@ static void dwc2_set_default_params(stru
        dwc2_set_param_speed(hsotg);
        dwc2_set_param_phy_utmi_width(hsotg);
        dwc2_set_param_power_down(hsotg);
@@ -49,7 +49,7 @@ Signed-off-by: Felipe Balbi <felipe.balbi@linux.intel.com>
        p->phy_ulpi_ddr = false;
        p->phy_ulpi_ext_vbus = false;
  
-@@ -302,11 +320,6 @@ static void dwc2_set_default_params(stru
+@@ -303,11 +321,6 @@ static void dwc2_set_default_params(stru
        p->reload_ctl = (hw->snpsid >= DWC2_CORE_REV_2_92a);
        p->uframe_sched = true;
        p->external_id_pin_ctl = false;
index 806e0f3c21d7c52b8a719999c2ad4d5e254cbcab..71a26dba4a7e85951dcdcb06e6fd33a166410b6a 100644 (file)
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  EXPORT_SYMBOL(default_qdisc_ops);
  
  /* Main transmission queue. */
-@@ -1013,7 +1013,7 @@ static void attach_one_default_qdisc(str
+@@ -1025,7 +1025,7 @@ static void attach_one_default_qdisc(str
                                     void *_unused)
  {
        struct Qdisc *qdisc;
index d545cdf7ee378af8879c7462ed10e4828c725f8f..e49507a5904472a6ed5cbf753b8cc84d94927c76 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/net/sched/sch_generic.c
 +++ b/net/sched/sch_generic.c
-@@ -600,207 +600,6 @@ struct Qdisc_ops noqueue_qdisc_ops __rea
+@@ -612,207 +612,6 @@ struct Qdisc_ops noqueue_qdisc_ops __rea
        .owner          =       THIS_MODULE,
  };
  
index e6a9c19cac06910204d0a21e468af99243a0c84d..ae032709d2729d23c3485c0a4e9ecbbfebd6d6a6 100644 (file)
  {
        int set;
  
-@@ -982,7 +982,7 @@ void radix__tlb_flush(struct mmu_gather
+@@ -983,7 +983,7 @@ void radix__tlb_flush(struct mmu_gather
        tlb->need_flush_all = 0;
  }
  
index f7803f0e3676be75f2706788c70811286a30f421..5ce652ba501794d8f3243d19a5252ab470dc3cb1 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        __u16                   tc_index;       /* traffic control index */
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -5468,6 +5468,9 @@ static enum gro_result dev_gro_receive(s
+@@ -5482,6 +5482,9 @@ static enum gro_result dev_gro_receive(s
        int same_flow;
        int grow;
  
@@ -42,7 +42,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (netif_elide_gro(skb->dev))
                goto normal;
  
-@@ -6962,6 +6965,48 @@ static void __netdev_adjacent_dev_unlink
+@@ -6976,6 +6979,48 @@ static void __netdev_adjacent_dev_unlink
                                           &upper_dev->adj_list.lower);
  }
  
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *upper_priv, void *upper_info,
-@@ -7009,6 +7054,7 @@ static int __netdev_upper_dev_link(struc
+@@ -7023,6 +7068,7 @@ static int __netdev_upper_dev_link(struc
        if (ret)
                return ret;
  
@@ -99,7 +99,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        ret = call_netdevice_notifiers_info(NETDEV_CHANGEUPPER,
                                            &changeupper_info.info);
        ret = notifier_to_errno(ret);
-@@ -7095,6 +7141,7 @@ void netdev_upper_dev_unlink(struct net_
+@@ -7109,6 +7155,7 @@ void netdev_upper_dev_unlink(struct net_
  
        __netdev_adjacent_dev_unlink_neighbour(dev, upper_dev);
  
@@ -107,7 +107,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER,
                                      &changeupper_info.info);
  }
-@@ -7718,6 +7765,7 @@ int dev_set_mac_address(struct net_devic
+@@ -7732,6 +7779,7 @@ int dev_set_mac_address(struct net_devic
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
index 90dc20b901be433bb235eda74993861972a7d0a4..fbdd117dea83db5bb185a43fc7add96941731857 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
  #include <linux/mtd/mtd.h>
  #include <linux/mtd/partitions.h>
-@@ -180,6 +181,10 @@ static int m25p_probe(struct spi_mem *sp
+@@ -173,6 +174,10 @@ static int m25p_probe(struct spi_mem *sp
        };
        char *flash_name;
        int ret;
@@ -33,7 +33,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
        data = dev_get_platdata(&spimem->spi->dev);
  
-@@ -218,6 +223,8 @@ static int m25p_probe(struct spi_mem *sp
+@@ -211,6 +216,8 @@ static int m25p_probe(struct spi_mem *sp
  
        if (data && data->name)
                nor->mtd.name = data->name;
index 90238e35b4ca2900e45d4c4f53920ad3415dfdb3..eed32d309788143d24762c1145f68bfa0a4f6765 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/i2c/busses/Kconfig
 +++ b/drivers/i2c/busses/Kconfig
-@@ -690,6 +690,16 @@ config I2C_MESON
+@@ -691,6 +691,16 @@ config I2C_MESON
          If you say yes to this option, support will be included for the
          I2C interface on the Amlogic Meson family of SoCs.
  
index 81d46c3d1e4d552105f88039009d6029b073c1db..fed65e532112ef561182576aa28e135a54840e64 100644 (file)
@@ -23,8 +23,8 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 
 --- a/drivers/usb/dwc2/params.c
 +++ b/drivers/usb/dwc2/params.c
-@@ -90,7 +90,14 @@ static void dwc2_set_rk_params(struct dw
-               GAHBCFG_HBSTLEN_SHIFT;
+@@ -91,7 +91,14 @@ static void dwc2_set_rk_params(struct dw
+       p->power_down = 0;
  }
  
 -static void dwc2_set_ltq_params(struct dwc2_hsotg *hsotg)
@@ -39,7 +39,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
  {
        struct dwc2_core_params *p = &hsotg->params;
  
-@@ -98,12 +105,20 @@ static void dwc2_set_ltq_params(struct d
+@@ -99,12 +106,20 @@ static void dwc2_set_ltq_params(struct d
        p->host_rx_fifo_size = 288;
        p->host_nperio_tx_fifo_size = 128;
        p->host_perio_tx_fifo_size = 96;
@@ -62,7 +62,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
  static void dwc2_set_amlogic_params(struct dwc2_hsotg *hsotg)
  {
        struct dwc2_core_params *p = &hsotg->params;
-@@ -155,8 +170,11 @@ const struct of_device_id dwc2_of_match_
+@@ -156,8 +171,11 @@ const struct of_device_id dwc2_of_match_
        { .compatible = "brcm,bcm2835-usb", .data = dwc2_set_bcm_params },
        { .compatible = "hisilicon,hi6220-usb", .data = dwc2_set_his_params  },
        { .compatible = "rockchip,rk3066-usb", .data = dwc2_set_rk_params },