autotools.mk: like libintl, make all libtool fixup packages depend on the libiconv...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Dec 2010 04:41:18 +0000 (04:41 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Dec 2010 04:41:18 +0000 (04:41 +0000)
SVN-Revision: 24708

include/autotools.mk

index 592fcdebd732d4dc460d14ef19d72c7762369dff..9bb984da7c6211093e0e6eb034dfe14eac064ca7 100644 (file)
@@ -61,14 +61,14 @@ define autoreconf_target
 endef
 
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool libintl
+  PKG_BUILD_DEPENDS += libtool libintl libiconv
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif
 endif
 
 ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool libintl
+  PKG_BUILD_DEPENDS += libtool libintl libiconv
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif