tools/cmake: Update to 3.12.3
authorDaniel Engberg <daniel.engberg.lists@pyret.net>
Sat, 6 Oct 2018 10:37:22 +0000 (12:37 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 7 Oct 2018 00:10:15 +0000 (02:10 +0200)
Update CMake to 3.12.3

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
tools/cmake/Makefile
tools/cmake/patches/140-libarchive-fix-libressl.patch

index a209fe3a814702e840bf83314fe258664efe1e11..9da08c468ddee7876ca8d75110aea87fca71b329 100644 (file)
@@ -7,13 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cmake
-PKG_VERSION:=3.12.2
+PKG_VERSION:=3.12.3
 PKG_CPE_ID:=cpe:/a:kitware:cmake
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://cmake.org/files/v3.12/ \
                https://fossies.org/linux/misc/
-PKG_HASH:=0f97485799e51a7070cc11494f3e02349b0fc3a24cc12b082e737bf67a0581a4
+PKG_HASH:=acbf13af31a741794106b76e5d22448b004a66485fc99f6d7df4d22e99da164a
 
 HOST_BUILD_PARALLEL:=1
 HOST_CONFIGURE_PARALLEL:=1
index ad8a0969a8ff43d5199ed5aa27d6cee87f3daaea..ddddc5e836d13fa5b9bca8f186071b39ef09ed9f 100644 (file)
@@ -11,18 +11,6 @@ Signed-off-by: Bernard Spil <brnrd@FreeBSD.org>
  libarchive/archive_openssl_hmac_private.h | 3 ++-
  1 file changed, 2 insertions(+), 1 deletion(-)
 
---- a/Utilities/cmlibarchive/libarchive/archive_openssl_hmac_private.h
-+++ b/Utilities/cmlibarchive/libarchive/archive_openssl_hmac_private.h
-@@ -28,7 +28,8 @@
- #include <openssl/hmac.h>
- #include <openssl/opensslv.h>
--#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || \
-+      (defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x20700000L)
- #include <stdlib.h> /* malloc, free */
- #include <string.h> /* memset */
- static inline HMAC_CTX *HMAC_CTX_new(void)
 --- a/Utilities/cmlibarchive/libarchive/archive_openssl_evp_private.h
 +++ b/Utilities/cmlibarchive/libarchive/archive_openssl_evp_private.h
 @@ -28,7 +28,8 @@