kernel: update 4.9 to 4.9.53
authorStijn Tintel <stijn@linux-ipv6.be>
Sat, 7 Oct 2017 15:08:53 +0000 (18:08 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Sat, 7 Oct 2017 17:53:21 +0000 (20:53 +0300)
Refresh patches.
Compile-tested on brcm2708/bcm2708, octeon and x86/64.
Runtime-tested on brcm2708/bcm2708, octeon and x86/64.

Fixes the following CVEs:
- CVE-2017-1000252
- CVE-2017-12153
- CVE-2017-12154

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
include/kernel-version.mk
target/linux/ramips/patches-4.9/0040-nand-hack.patch

index bf38d8667ba0e619aefab48c2b09f9faaa396e4d..75a1e1d708ff461ed12c9c15f1d98ff1167146f8 100644 (file)
@@ -4,11 +4,11 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .71
 LINUX_VERSION-4.4 = .90
-LINUX_VERSION-4.9 = .52
+LINUX_VERSION-4.9 = .53
 
 LINUX_KERNEL_HASH-3.18.71 = 5abc9778ad44ce02ed6c8ab52ece8a21c6d20d21f6ed8a19287b4a38a50c1240
 LINUX_KERNEL_HASH-4.4.90 = 6826ccd213ac79bbfd47e63912e89ef7ec70324b7aa3684a4d4560fc2b436331
-LINUX_KERNEL_HASH-4.9.52 = ffdd034f1bf32fa41d1a66a347388c0dc4c3cff6f578a1e29d88b20fbae1048a
+LINUX_KERNEL_HASH-4.9.53 = 32915a33bb0b993b779257748f89f31418992edba53acbe1160cb0f8ef3cb324
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 64a325300e426022007bb5faa07b4bbecc4a16e7..fe2b12d2ceb713d73e9167a143c1e83154874351 100644 (file)
@@ -41,7 +41,7 @@
        }
 --- a/drivers/mtd/nand/nand_device_list.h
 +++ b/drivers/mtd/nand/nand_device_list.h
-@@ -43,6 +43,8 @@ static const flashdev_info gen_FlashTabl
+@@ -44,6 +44,8 @@ static const flashdev_info gen_FlashTabl
        {0xADBC, 0x905554, 5, 16, 512, 128, 2048, 64, 0x10801011, "H9DA4GH4JJAMC", 0},
      {0x01F1, 0x801D01, 4, 8, 128, 128, 2048, 64, 0x30C77fff, "S34ML01G100TF", 0},
      {0x92F1, 0x8095FF, 4, 8, 128, 128, 2048, 64, 0x30C77fff, "F59L1G81A", 0},