automake: portability fixes
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 24 Mar 2015 13:13:01 +0000 (13:13 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 24 Mar 2015 13:13:01 +0000 (13:13 +0000)
The rework of the host tools discovery caused automake to embed
absolute paths to staging_dir/host/bin/perl into the shebang
of the generated automake executables.

Switch to the portable "/usr/bin/env perl" and enable global
warnings through "$^W" instead of the "-w" interpreter argument.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44972

tools/automake/Makefile
tools/automake/patches/000-relocatable.patch
tools/automake/patches/100-aclocal-skip-not-existing-directories.patch

index 6395d84387d74669a37fece0f463f373c142f504..0eea1019830052a94b86b97cf18ab5a408d762b4 100644 (file)
@@ -19,7 +19,9 @@ HOST_CONFIGURE_ARGS += \
        --datarootdir=$(STAGING_DIR_HOST)/share \
        --disable-silent-rules
 
-HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
+HOST_CONFIGURE_VARS += \
+       PERL="/usr/bin/env perl" \
+       am_cv_prog_PERL_ithreads=no
 
 define Host/Configure
        (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) STAGING_DIR="" ./bootstrap.sh)
index 8e9ee37db49fb9dd77bccb6fc97a26e4d8d84ea0..59864f2ad5302da235d06e5efabf1fea6804aca5 100644 (file)
  # We need at least this version for CLONE support.
 --- a/bin/aclocal.in
 +++ b/bin/aclocal.in
-@@ -27,7 +27,7 @@ eval 'case $# in 0) exec @PERL@ -S "$0";
+@@ -1,10 +1,12 @@
+-#!@PERL@ -w
++#!@PERL@
+ # -*- perl -*-
+ # @configure_input@
+ eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
+     if 0;
++$^W = 1;
++
+ # aclocal - create aclocal.m4 by scanning configure.ac
+ # Copyright (C) 1996-2014 Free Software Foundation, Inc.
+@@ -27,7 +29,7 @@ eval 'case $# in 0) exec @PERL@ -S "$0";
  
  BEGIN
  {
@@ -20,7 +34,7 @@
      unless @Aclocal::perl_libdirs;
    unshift @INC, @Aclocal::perl_libdirs;
  }
-@@ -69,8 +69,8 @@ $perl_threads = 0;
+@@ -69,8 +71,8 @@ $perl_threads = 0;
  # ACLOCAL_PATH environment variable, and reset with the '--system-acdir'
  # option.
  my @user_includes = ();
  my $install = 0;
 --- a/bin/automake.in
 +++ b/bin/automake.in
-@@ -31,7 +31,7 @@ use strict;
+@@ -1,10 +1,12 @@
+-#!@PERL@ -w
++#!@PERL@
+ # -*- perl -*-
+ # @configure_input@
+ eval 'case $# in 0) exec @PERL@ -S "$0";; *) exec @PERL@ -S "$0" "$@";; esac'
+     if 0;
++$^W = 1;
++
+ # automake - create Makefile.in from Makefile.am
+ # Copyright (C) 1994-2014 Free Software Foundation, Inc.
+@@ -31,7 +33,7 @@ use strict;
  
  BEGIN
  {
      unless @Automake::perl_libdirs;
    unshift @INC, @Automake::perl_libdirs;
  
+--- a/t/wrap/aclocal.in
++++ b/t/wrap/aclocal.in
+@@ -1,6 +1,8 @@
+-#!@PERL@ -w
++#!@PERL@
+ # @configure_input@
++$^W = 1;
++
+ # Copyright (C) 2012-2014 Free Software Foundation, Inc.
+ # This program is free software; you can redistribute it and/or modify
+--- a/t/wrap/automake.in
++++ b/t/wrap/automake.in
+@@ -1,6 +1,8 @@
+-#!@PERL@ -w
++#!@PERL@
+ # @configure_input@
++$^W = 1;
++
+ # Copyright (C) 2012-2014 Free Software Foundation, Inc.
+ # This program is free software; you can redistribute it and/or modify
index caaad084a4996a4ad8afca3411381382f6ff8e2c..ad019ddd1ae8cf9dabdd66d799e471c89e7233bd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/bin/aclocal.in
 +++ b/bin/aclocal.in
-@@ -354,6 +354,12 @@ sub scan_m4_dirs ($$@)
+@@ -356,6 +356,12 @@ sub scan_m4_dirs ($$@)
  
    foreach my $m4dir (@dirlist)
      {