tools/mtd-utils: fix compilation on OS X
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 2 Oct 2010 10:18:34 +0000 (10:18 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 2 Oct 2010 10:18:34 +0000 (10:18 +0000)
SVN-Revision: 23176

tools/mtd-utils/patches/131-fix_lib_compile.patch

index f40a5b6c56b9ab7a8dd06da29511b3a4efbfe8c4..fef133317718904f7d66f65f0f3e40681794b6bb 100644 (file)
@@ -1,11 +1,11 @@
---- a/Makefile
-+++ b/Makefile
-@@ -68,8 +68,6 @@ $(BUILDDIR)/jffs2reader: $(BUILDDIR)/jff
- LDFLAGS_jffs2reader = $(ZLIBLDFLAGS) $(LZOLDFLAGS)
- LDLIBS_jffs2reader  = -lz -llzo2
+--- a/lib/Makefile
++++ b/lib/Makefile
+@@ -7,7 +7,7 @@ SUBDIRS =
+ # CFLAGS += -Werror
+ CPPFLAGS += -I../include
+ LIBS = libmtd libcrc32
+-TARGETS = libmtd.a libcrc32.a
++override TARGETS = libmtd.a libcrc32.a
+ include ../common.mk
  
--$(BUILDDIR)/lib/libmtd.a: subdirs_lib_all ;
--
- install:: ${TARGETS} ${SCRIPTS}
-       mkdir -p ${DESTDIR}/${SBINDIR}
-       install -m 0755 ${TARGETS} ${SCRIPTS} ${DESTDIR}/${SBINDIR}/