ath10k-ct: update to version 2020-06-30
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Wed, 1 Jul 2020 09:46:48 +0000 (11:46 +0200)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Wed, 1 Jul 2020 13:39:15 +0000 (15:39 +0200)
Backports commit "a1769bb68a850508a492e3674ab1e5e479b11254", which reverts
upstream commit "76d164f582150fd0259ec0fcbc485470bcd8033e" (ath10k: fix DMA
related firmware crashes on multiple devices).

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
package/kernel/ath10k-ct/Makefile
package/kernel/ath10k-ct/patches/201-ath10k-add-LED-and-GPIO-controlling-support-for-various-chipsets.patch
package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch
package/kernel/ath10k-ct/patches/205-ath10k-Add-NL80211_EXT_FEATURE_AQL-flag.patch

index 16930a13a886b4336cf48b19c9054a7da86e3d59..76077ec156c2cb961fd90636de2b0fca8d8a73cd 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2020-04-29
-PKG_SOURCE_VERSION:=3637be6f6baf99e85a7f0b27f80a99a2f2a5f78d
-PKG_MIRROR_HASH:=97cf22a4a57381c7eb7a9b8a8b1e347e9711ce51c89db971b4ab9a35af476ece
+PKG_SOURCE_DATE:=2020-06-30
+PKG_SOURCE_VERSION:=edfbf9161ab75e4831981284ab2d5b1b9fb6ef72
+PKG_MIRROR_HASH:=98b7f88baea7314144fa8f8d141ad0dbbf2816f9606b0a89afb396761b558d14
 
 # Build the 5.4 ath10k-ct driver version.  Other option is "-4.19".
 # Probably this should match as closely as
index c20800209d5399179d7f768a91abb45849bf4ca0..15343abd5f8760443f96a4555642851a3ff3ee4e 100644 (file)
@@ -210,7 +210,7 @@ v13:
  
  #include "htt.h"
  #include "htc.h"
-@@ -1469,6 +1470,13 @@ struct ath10k {
+@@ -1470,6 +1471,13 @@ struct ath10k {
        } testmode;
  
        struct {
@@ -445,7 +445,7 @@ v13:
  {
 --- a/ath10k-5.4/wmi-tlv.c
 +++ b/ath10k-5.4/wmi-tlv.c
-@@ -4364,6 +4364,8 @@ static const struct wmi_ops wmi_tlv_ops
+@@ -4367,6 +4367,8 @@ static const struct wmi_ops wmi_tlv_ops
        .gen_echo = ath10k_wmi_tlv_op_gen_echo,
        .gen_vdev_spectral_conf = ath10k_wmi_tlv_op_gen_vdev_spectral_conf,
        .gen_vdev_spectral_enable = ath10k_wmi_tlv_op_gen_vdev_spectral_enable,
@@ -456,7 +456,7 @@ v13:
  static const struct wmi_peer_flags_map wmi_tlv_peer_flags_map = {
 --- a/ath10k-5.4/wmi.c
 +++ b/ath10k-5.4/wmi.c
-@@ -8295,6 +8295,49 @@ ath10k_wmi_op_gen_peer_set_param(struct
+@@ -8305,6 +8305,49 @@ ath10k_wmi_op_gen_peer_set_param(struct
        return skb;
  }
  
@@ -506,7 +506,7 @@ v13:
  static struct sk_buff *
  ath10k_wmi_op_gen_set_psmode(struct ath10k *ar, u32 vdev_id,
                             enum wmi_sta_ps_mode psmode)
-@@ -10094,6 +10137,9 @@ static const struct wmi_ops wmi_ops = {
+@@ -10104,6 +10147,9 @@ static const struct wmi_ops wmi_ops = {
        .fw_stats_fill = ath10k_wmi_main_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
        .gen_echo = ath10k_wmi_op_gen_echo,
@@ -516,7 +516,7 @@ v13:
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10164,6 +10210,8 @@ static const struct wmi_ops wmi_10_1_ops
+@@ -10174,6 +10220,8 @@ static const struct wmi_ops wmi_10_1_ops
        .fw_stats_fill = ath10k_wmi_10x_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
        .gen_echo = ath10k_wmi_op_gen_echo,
@@ -525,7 +525,7 @@ v13:
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10243,6 +10291,8 @@ static const struct wmi_ops wmi_10_2_ops
+@@ -10253,6 +10301,8 @@ static const struct wmi_ops wmi_10_2_ops
        .gen_delba_send = ath10k_wmi_op_gen_delba_send,
        .fw_stats_fill = ath10k_wmi_10x_op_fw_stats_fill,
        .get_vdev_subtype = ath10k_wmi_op_get_vdev_subtype,
@@ -534,7 +534,7 @@ v13:
        /* .gen_pdev_enable_adaptive_cca not implemented */
  };
  
-@@ -10314,6 +10364,8 @@ static const struct wmi_ops wmi_10_2_4_o
+@@ -10324,6 +10374,8 @@ static const struct wmi_ops wmi_10_2_4_o
                ath10k_wmi_op_gen_pdev_enable_adaptive_cca,
        .get_vdev_subtype = ath10k_wmi_10_2_4_op_get_vdev_subtype,
        .gen_bb_timing = ath10k_wmi_10_2_4_op_gen_bb_timing,
@@ -543,7 +543,7 @@ v13:
        /* .gen_bcn_tmpl not implemented */
        /* .gen_prb_tmpl not implemented */
        /* .gen_p2p_go_bcn_ie not implemented */
-@@ -10395,6 +10447,8 @@ static const struct wmi_ops wmi_10_4_ops
+@@ -10405,6 +10457,8 @@ static const struct wmi_ops wmi_10_4_ops
        .gen_pdev_bss_chan_info_req = ath10k_wmi_10_2_op_gen_pdev_bss_chan_info,
        .gen_echo = ath10k_wmi_op_gen_echo,
        .gen_pdev_get_tpc_config = ath10k_wmi_10_2_4_op_gen_pdev_get_tpc_config,
index b1c7bae193099e8d587f1f5d6c25b86bb431ec06..dd35e2937cc9951d4ce6b3615f1bd71070e427cb 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
 
 --- a/ath10k-5.4/core.h
 +++ b/ath10k-5.4/core.h
-@@ -1573,6 +1573,10 @@ struct ath10k {
+@@ -1574,6 +1574,10 @@ struct ath10k {
        u8 csi_data[4096];
        u16 csi_data_len;
  
@@ -42,7 +42,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
        if (ret)
 --- a/ath10k-5.4/mac.c
 +++ b/ath10k-5.4/mac.c
-@@ -10367,7 +10367,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -10383,7 +10383,7 @@ int ath10k_mac_register(struct ath10k *a
        ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER;
  
  #ifdef CPTCFG_MAC80211_LEDS
index 41b917089c11b611262c7237a711fcdfb04e41ef..33d69e7975b138a492211135b259d2171896c99b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/ath10k-5.4/mac.c
 +++ b/ath10k-5.4/mac.c
-@@ -10180,6 +10180,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -10182,6 +10182,7 @@ int ath10k_mac_register(struct ath10k *a
        wiphy_ext_feature_set(ar->hw->wiphy, NL80211_EXT_FEATURE_VHT_IBSS);
        wiphy_ext_feature_set(ar->hw->wiphy,
                              NL80211_EXT_FEATURE_SET_SCAN_DWELL);