upgrade to latest kernel versions (2.6.25.4; 2.6.24.7; 2.6.23.17; 2.6.22.19)
authorGabor Juhos <juhosg@openwrt.org>
Sun, 18 May 2008 20:12:54 +0000 (20:12 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 18 May 2008 20:12:54 +0000 (20:12 +0000)
SVN-Revision: 11184

23 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar7/Makefile
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/etrax/Makefile
target/linux/ifxmips/Makefile
target/linux/iop32x/Makefile
target/linux/ixp4xx/Makefile
target/linux/magicbox/Makefile
target/linux/olpc/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ps3/Makefile
target/linux/rb532/Makefile
target/linux/rdc/Makefile
target/linux/sibyte/Makefile
target/linux/storm/Makefile
target/linux/uml/Makefile
target/linux/x86/Makefile

index f43810653635d81770dfbe22d6a4560f1acd57cc..aba715f9206256bca754618f04ab170396a8ed4b 100644 (file)
@@ -3,7 +3,7 @@
 ifeq ($(KERNEL),2.4)
   LINUX_VERSION?=2.4.35.4
 else
-  LINUX_VERSION?=2.6.21.5
+  LINUX_VERSION?=2.6.21.7
 endif
 LINUX_RELEASE?=1
 
@@ -16,17 +16,17 @@ endif
 ifeq ($(LINUX_VERSION),2.6.21.7)
   LINUX_KERNEL_MD5SUM:=bc15fad1487336d5dcb0945cd039d8ed
 endif
-ifeq ($(LINUX_VERSION),2.6.22.18)
-  LINUX_KERNEL_MD5SUM:=bd375d5885bf114c74a2216d52d86e34
+ifeq ($(LINUX_VERSION),2.6.22.19)
+  LINUX_KERNEL_MD5SUM:=4db27facb78aeb79d06e6ae6bf0ac0b6
 endif
-ifeq ($(LINUX_VERSION),2.6.23.16)
-  LINUX_KERNEL_MD5SUM:=2637a7f1d4450bc5e27422f307fc6529
+ifeq ($(LINUX_VERSION),2.6.23.17)
+  LINUX_KERNEL_MD5SUM:=a0300a393ac91ce9c64bf31522b45e2e
 endif
-ifeq ($(LINUX_VERSION),2.6.24.5)
-  LINUX_KERNEL_MD5SUM:=26500f8f92895bd33e391088b5edd4ad
+ifeq ($(LINUX_VERSION),2.6.24.7)
+  LINUX_KERNEL_MD5SUM:=40a73780d51525d28d36dec852c680c4
 endif
-ifeq ($(LINUX_VERSION),2.6.25.1)
-  LINUX_KERNEL_MD5SUM:=0d26fcafa00dc5cf27d4bf01301409a0
+ifeq ($(LINUX_VERSION),2.6.25.4)
+  LINUX_KERNEL_MD5SUM:=c2ec5007ee62e1b1ab05a1ca9155ebd3
 endif
 
 # disable the md5sum check for unknown kernel versions
index ec700989680dd03fa5ec2e47a70cf39b9be84930..af250e7dbc2dbc9649d8b3de9590aaf642636904 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
index 3abf34edd281893bcd331571a164394c2934d2d8..f5c6b9950f75435de875c8f6104caeb7a059bc3f 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.25.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 87f156a43af066e0bb791cd4c54f942d51818901..8a7d33019b79780ae8304ec91fc3f535e0c418d1 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=at91
 BOARDNAME:=Atmel AT91
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.21.7
 
 include $(INCLUDE_DIR)/target.mk
 
index ab301ba5098aa26894405d333bebfc6dec57b31c..5f5f9e44658da0529f7228906e4a201fb9602fc8 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros 231x/5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.23.16
+LINUX_VERSION:=2.6.23.17
 
 include $(INCLUDE_DIR)/target.mk
 
index ec1a959ed2955c58f028f1e6e84a4b244e265784..5a081f124d312ed0b672885552d4eb2fb3d8eba1 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 50b60f169980a33e6dcebb9082af417a693d183e..24f13af0a17fe74fb4f8a03a907e0357f626bafe 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.23.16
+LINUX_VERSION:=2.6.23.17
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-switch kmod-diag
index 56d14918b512f87a2b5f48231ca335119a9e14d1..2af52105e4dd5f772668c60326e2fd3c581cb944 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
 FEATURES:=squashfs jffs2 broken usb atm
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 119dbb29d70dcced785ca9cffa2a206d3f3decc4..db615ce1491780041cf190a940b1296602f26937 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=cris
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
 FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.25.4
 
 include $(INCLUDE_DIR)/target.mk
 
index ea5fa0afb5efc8bf1fa544495c63f33f36b55ce6..bfe84fe3402b51e1a6e6f6b33de71143cce8ef75 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.25.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 4cb4ad6500f83acbda269ba19ee2479863537594..f7556c2e80aa69a88e31373885ae701badcb0dc3 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=iop32x
 BOARDNAME:=Intel IOP32x
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
index b02e749cd1dc0a6458538a054472eeabb5b47767..e6b15e537bae52316edb5c960a5cd13fcd35193c 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.25.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 548b960c1bff2b257998e0194af0a24ae4b44184..d539f98f4c72d6428ca125c9ebbd8a7fa1ea6eca 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=magicbox
 BOARDNAME:=Magicbox
 FEATURES:=squashfs pci
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 LINUX_KARCH:=ppc
 
 include $(INCLUDE_DIR)/target.mk
index 9548b7b8771a7914185939dd67771b580bef1ebe..915d11acbd65f40a063b8f54a6e6636dd8826453 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=olpc
 BOARDNAME:=OLPC XO-1
 FEATURES:=squashfs ext2
 
-LINUX_VERSION:=2.6.23.16
+LINUX_VERSION:=2.6.23.17
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
index 11b052a2d6bb44889e3a983297f48e9f3a4c8414..a571a19241724da962fcac9fdb5c5383e388ca1f 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 1e4b9ed2be7de79b9d8dc25ab2b215ab07bb0f76..90921e097de9504e18bec2a2cafdd654633d21d6 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 5bec1f58051b4a46561dc6588b4717e24d1b0067..14dbc9779680d4c739744cc59988c4fc56b63f53 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=powerpc
 BOARD:=ps3
 BOARDNAME:=Sony PS3 Game Console
 
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.25.4
 
 KERNEL_CC:=
 
index 9e4fcca5ef3556c144a0d80146a9b72704065797..43ad5453b07a3798d25dedee95081b4b10eeb3d3 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci tgz
 
-LINUX_VERSION:=2.6.23.16
+LINUX_VERSION:=2.6.23.17
 
 include $(INCLUDE_DIR)/target.mk
 
index 42d4123bfc03b04cde3920e6df06d7d16376b32a..0b708fc8565adb8571066bb6424798657fdf4a3c 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rdc
 BOARDNAME:=RDC 321x
 FEATURES:=squashfs jffs2 pci
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
index df4539ca935102036d79f656eb216cfca44308b1..ac3633f61a00d4805c20a892da1e1eb1139f2209 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=sibyte
 BOARDNAME:=Broadcom/SiByte SB-1
 FEATURES:=broken
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
index c0d0023cc1e4582ba551b0b732c1fd546f595d95..abd6b0cc384b054f37f14735b1bfcdeed6ddc397 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=storm
 BOARDNAME:=Storm SL3512
 FEATURES:=squashfs pci broken
 
-LINUX_VERSION:=2.6.23.16
+LINUX_VERSION:=2.6.23.17
 
 include $(INCLUDE_DIR)/target.mk
 
index 543f7036e2e5a5e9b0e92c8d7cae83919140717b..022098a8383f8145799646427f28824674da66d3 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=broken ext2
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
-LINUX_VERSION:=2.6.24.5
+LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 9943210312418fa2a55148493b464eb89f20b6d1..f85760b28bd2974a3922bf4f0b8a9cd36290d359 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2
 SUBTARGETS=generic
 
-LINUX_VERSION:=2.6.25.1
+LINUX_VERSION:=2.6.25.4
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci