libcxx: Depenency fixes
authorRosen Penev <rosenp@gmail.com>
Mon, 23 Dec 2019 01:41:15 +0000 (17:41 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 23 Dec 2019 11:08:23 +0000 (12:08 +0100)
Don't build with uClibc-ng. It's totally unsupported as several functions
are missing.

Make the musl libc support conditional.

Fix hash with make check FIXUP=1. Apparently I based the Makefile off of
libedit and forgot to fix the hash.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
Fixes: 856ea2bad3b3 ("libcxx: Add package")
config/Config-build.in
package/libs/libcxx/Makefile

index bde5730e7618dbf65938963d3bd2d06d98fd3bc0..c0e4d869f873dcdef39c42061dded021c9b02b22 100644 (file)
@@ -199,6 +199,7 @@ menu "Global build settings"
 
                config USE_LIBCXX
                        bool "libc++"
+                       depends on !USE_UCLIBC
 
                config USE_LIBSTDCXX
                        bool "libstdc++"
index c1fa1d6b0776d134087253553578bf27b3136f3d..695b0398feade39800ccf8465ec0b3de202d4c4c 100644 (file)
@@ -7,12 +7,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libcxx
 PKG_VERSION:=9.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://git.llvm.org/git/libcxx
 PKG_SOURCE_VERSION:=2076f539f410805ef88692b9c0ce0a0b882a7680
-PKG_MIRROR_HASH:=6dff036660d478bfaa14e407fc5de26d22da1087118c897b1a3ad2e90cb7bf39
+PKG_MIRROR_HASH:=d527880a18dec9109575c76717cf5288fb91c11381b9d261cae2e5bebcbdab2e
 
 PKG_MAINTAINER:=Rosen Penev <rosenp@gmail.com>
 PKG_LICENSE:=MIT
@@ -42,8 +42,8 @@ CMAKE_OPTIONS += \
        -DLIBCXX_INCLUDE_BENCHMARKS=OFF \
        -DLIBCXX_INCLUDE_DOCS=OFF \
        -DLIBCXX_INCLUDE_TESTS=OFF \
-       -DLIBCXX_HAS_MUSL_LIBC=ON \
-       -DLIBCXX_STANDALONE_BUILD=ON
+       -DLIBCXX_STANDALONE_BUILD=ON \
+       -DLIBCXX_HAS_MUSL_LIBC=$(if $(CONFIG_USE_MUSL),ON,OFF)
 
 TARGET_CXXFLAGS += -D_LIBCPP_DISABLE_DEPRECATION_WARNINGS -Wno-attributes -flto
 TARGET_LDFLAGS += -Wl,--as-needed