build: filter out kmod-ipt-offload from the default selection on targets that do...
authorFelix Fietkau <nbd@nbd.name>
Thu, 29 Mar 2018 14:12:43 +0000 (16:12 +0200)
committerFelix Fietkau <nbd@nbd.name>
Fri, 30 Mar 2018 07:34:25 +0000 (00:34 -0700)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/target.mk

index d4950e5b2be47c813190db66f08ba87cab843ae4..8d5ae1e1d3aead6e5a73c75da31e6760c21a74b3 100644 (file)
@@ -51,6 +51,10 @@ else
   endif
 endif
 
+ifneq ($(filter 3.18 4.4 4.9,$(KERNEL_PATCHVER)),)
+  DEFAULT_PACKAGES.router:=$(filter-out kmod-ipt-offload,$(DEFAULT_PACKAGES.router))
+endif
+
 # Add device specific packages (here below to allow device type set from subtarget)
 DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))