base-files: move /tmp/resolv.conf.auto to /tmp/resolv.conf.d/
authorDaniel Golle <daniel@makrotopia.org>
Wed, 1 Jan 2020 02:11:54 +0000 (04:11 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Tue, 7 Jan 2020 13:36:03 +0000 (15:36 +0200)
Having it in a directory it more friendly for mount-bind.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/base-files/Makefile
package/base-files/files/etc/init.d/boot
package/network/services/ipset-dns/files/ipset-dns.config

index f203c29e95accb91127b09b6d5d8df830efe6a8b..35ad80888f070d6c1426c912a22d31ae1217d09f 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=211
+PKG_RELEASE:=212
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
index 09b7f44c794a11ff6e49796454483754cca5ac4b..44311c9e230ec5debc5305a12475035ba32da30f 100755 (executable)
@@ -31,8 +31,9 @@ boot() {
        chmod 0700 /tmp/.uci
        touch /var/log/wtmp
        touch /var/log/lastlog
-       touch /tmp/resolv.conf.auto
-       ln -sf /tmp/resolv.conf.auto /tmp/resolv.conf
+       mkdir -p /tmp/resolv.conf.d
+       touch /tmp/resolv.conf.d/resolv.conf.auto
+       ln -sf /tmp/resolv.conf.d/resolv.conf.auto /tmp/resolv.conf
        grep -q debugfs /proc/filesystems && /bin/mount -o noatime -t debugfs debugfs /sys/kernel/debug
        [ "$FAILSAFE" = "true" ] && touch /tmp/.failsafe
 
index 0270366af755ac0e96fd26bea76d46a99a2cb88f..538d3a01a3d32a485dc5203d2fecf68af2b63177 100644 (file)
@@ -11,6 +11,6 @@ config ipset-dns
        #option port  '53001'
 
        # use given upstream DNS server,
-       # defaults to first entry in /tmp/resolv.conf.auto
+       # defaults to first entry in /tmp/resolv.conf.d/resolv.conf.auto
        #option dns   '8.8.8.8'