lua: honor LDFLAGS
authorSteven Barth <cyrus@openwrt.org>
Thu, 18 Jun 2015 10:55:57 +0000 (10:55 +0000)
committerSteven Barth <cyrus@openwrt.org>
Thu, 18 Jun 2015 10:55:57 +0000 (10:55 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 46036

package/utils/lua/patches/050-honor-cflags.patch [new file with mode: 0644]

diff --git a/package/utils/lua/patches/050-honor-cflags.patch b/package/utils/lua/patches/050-honor-cflags.patch
new file mode 100644 (file)
index 0000000..dd65791
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -56,7 +56,7 @@ $(LUA_A): $(CORE_O) $(LIB_O)
+       $(RANLIB) $@
+ $(LUA_SO): $(CORE_O) $(LIB_O)
+-      $(CC) -o $@.$(PKG_VERSION) -Wl,-Bsymbolic-functions -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
++      $(CC) -o $@.$(PKG_VERSION) -Wl,-Bsymbolic-functions $(MYLDFLAGS) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
+       ln -fs $@.$(PKG_VERSION) $@
+