ar71xx: Add support for Ubiquity Bullet M (XW)
authorPetr Štetiar <ynezz@true.cz>
Sat, 17 Nov 2018 07:01:55 +0000 (08:01 +0100)
committerPetr Štetiar <ynezz@true.cz>
Mon, 8 Apr 2019 16:37:04 +0000 (18:37 +0200)
CPU: AR9342 SoC
RAM:     64 MB DDR2
Flash:    8 MB NOR SPI
Ports:  100 MBit (24V PoE in)
WLAN: 2.4/5 GHz
UART:     1 UART on PCB marked as J1 with 115200 8N1 config
LEDs:       Power, Ethernet, 4x RSSI LEDs (orange, red, 2x green)
Buttons:    Reset

UART connection details

  .---------------------------------.
  |                                 |
[ETH]          J1                 [ANT]
  |    o VCC o RX o TX o GND        |
  `---------------------------------'

Flashing instructions using recovery method over TFTP

 1. Unplug the ethernet cable from the router.
 2. Using paper clip press and hold the router's reset button. Make sure
    you can feel it depressed by the paper clip. Do not release the button
    until step 4.
 3. While keeping the reset button pressed in, plug the ethernet cable
    back into the AP. Keep the reset button depressed until you see the
    device's LEDs flashing in upgrade mode (alternating LED1/LED3 and
    LED2/LED4), this may take up to 25 seconds.
 4. You may release the reset button, now the device should be in TFTP
    transfer mode.
 5. Set a static IP on your Computer's NIC. A static IP of 192.168.1.25/24
    should work.
 6. Plug the PoE injector's LAN cable directly to your computer.
 7. Start tftp client and issue following commands:
     tftp> binary
     tftp> connect 192.168.1.20
     tftp> put openwrt-ar71xx-generic-ubnt-bullet-m-xw-squashfs-factory.bin

Tested only on Bullet M2HP.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ar71xx/base-files/etc/board.d/01_leds
target/linux/ar71xx/base-files/etc/board.d/02_network
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/files/arch/mips/ath79/mach-ubnt-xm.c
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/image/generic-ubnt.mk

index 79f452d8cfe201246f185ee0015b75fae8c3f7da..41dd8c52ea0c869d23ae6823fb50a6f924f3b211 100755 (executable)
@@ -179,6 +179,7 @@ bsb)
        ucidef_set_led_default "sys" "SYS" "$board:red:sys" "1"
        ;;
 bullet-m|\
+bullet-m-xw|\
 loco-m-xw|\
 nanostation-m|\
 nanostation-m-xw|\
index a7b97bb3dd171cde41f8d8460936675a3abb3308..8e5ff101d6fb35f17a4bab8990dc49f29d9074a0 100755 (executable)
@@ -68,6 +68,7 @@ ar71xx_setup_interfaces()
        ap91-5g|\
        aw-nr580|\
        bullet-m|\
+       bullet-m-xw|\
        c-55|\
        cap324|\
        cap4200ag|\
index 55654263af628cedebfd08d18566892bcad50e35..558f338cd630529b2eef2147274ccec28485e354 100644 (file)
@@ -129,6 +129,7 @@ get_status_led() {
                status_led="$board:red:sys"
                ;;
        bullet-m|\
+       bullet-m-xw|\
        loco-m-xw|\
        nano-m|\
        nanostation-m|\
index 56a4fab80c8ee58c1e14cf33a70f0b94052b523b..990683a55b45a0169b54483fbccd5da8b6a3c2da 100755 (executable)
@@ -530,6 +530,9 @@ ar71xx_board_detect() {
                name="bullet-m"
                ubnt_xm_board_detect
                ;;
+       *"Bullet M XW")
+               name="bullet-m-xw"
+               ;;
        *"BXU2000n-2 rev. A1")
                name="bxu2000n-2-a1"
                ;;
index 7fc3d4e3b3a4923a799b439a7bb0f6bae685fa42..81735017e5a0a7137f6add816e65222f533d2c64 100755 (executable)
@@ -218,6 +218,7 @@ platform_check_image() {
        archer-c7-v4|\
        archer-c7-v5|\
        bullet-m|\
+       bullet-m-xw|\
        c-55|\
        carambola2|\
        cf-e316n-v2|\
index ba79537b37c1a70c76d2d0bba72132b6f42af2ae..6ceb91efff573ad0fa92caa95660875f126fef6d 100644 (file)
@@ -656,6 +656,9 @@ MIPS_MACHINE(ATH79_MACH_UBNT_LOCO_M_XW, "UBNT-LOCO-XW", "Ubiquiti Loco M XW",
 MIPS_MACHINE(ATH79_MACH_UBNT_ROCKET_M_XW, "UBNT-RM-XW", "Ubiquiti Rocket M XW",
             ubnt_rocket_m_xw_setup);
 
+MIPS_MACHINE(ATH79_MACH_UBNT_BULLET_M_XW, "UBNT-BM-XW", "Ubiquiti Bullet M XW",
+            ubnt_rocket_m_xw_setup);
+
 MIPS_MACHINE(ATH79_MACH_UBNT_ROCKET_M_TI, "UBNT-RM-TI", "Ubiquiti Rocket M TI",
             ubnt_rocket_m_ti_setup);
 
index fb832390c14fbe33ccf178ea1016d4981d3473e6..9722744a37d04dec6fe233d7f7faceb3947fa893 100644 (file)
@@ -321,6 +321,7 @@ enum ath79_mach_type {
        ATH79_MACH_UBNT_AIRGWP,                 /* Ubiquiti AirGateway Pro */
        ATH79_MACH_UBNT_AIRROUTER,              /* Ubiquiti AirRouter */
        ATH79_MACH_UBNT_BULLET_M,               /* Ubiquiti Bullet M */
+       ATH79_MACH_UBNT_BULLET_M_XW,            /* Ubiquiti Bullet M XW */
        ATH79_MACH_UBNT_LBE_M5,                 /* Ubiquiti Litebeam M5 */
        ATH79_MACH_UBNT_LOCO_M_XW,              /* Ubiquiti Loco M XW */
        ATH79_MACH_UBNT_LSSR71,                 /* Ubiquiti LS-SR71 */
index 84471a5c50f31e0565bf1ce6455598d6754fb945..5caad50b0ad1de2d07a8363896bd4155de405853 100644 (file)
@@ -188,6 +188,13 @@ define Device/ubnt-loco-m-xw
 endef
 TARGET_DEVICES += ubnt-loco-m-xw
 
+define Device/ubnt-bullet-m-xw
+  $(Device/ubnt-xw)
+  DEVICE_TITLE := Ubiquiti Bullet-M XW
+  BOARDNAME := UBNT-BM-XW
+endef
+TARGET_DEVICES += ubnt-bullet-m-xw
+
 define Device/ubnt-rocket-m-xw
   $(Device/ubnt-xw)
   DEVICE_TITLE := Ubiquiti Rocket M XW