busybox: use $(AUTORELEASE) and SPDX
authorPaul Spooren <mail@aparcar.org>
Tue, 18 May 2021 13:36:10 +0000 (15:36 +0200)
committerBaptiste Jonglez <git@bitsofnetworks.org>
Wed, 26 May 2021 22:03:05 +0000 (00:03 +0200)
use AUTORELEASE since BusyBox is often updaten and PKG_RELEASE is not
consistently bumped. Also use SPDX license headers to be machine
readable and bump the copyright year to 2021.

Signed-off-by: Paul Spooren <mail@aparcar.org>
(cherry picked from commit 25fdb42249aef7b5eb53675f82f0091c532bf90c)

package/utils/busybox/Makefile

index 475a154fa35f8719d1b94c88eb84ff8ebbfea707..0d5e42094395f8206b01d8a2fdd60db6d0af5e5a 100644 (file)
@@ -1,15 +1,12 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
 #
-# Copyright (C) 2006-2020 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2006-2021 OpenWrt.org
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.33.1
-PKG_RELEASE:=1
+PKG_RELEASE:=$(AUTORELEASE)
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2