fix for GREP_OPTIONS
[openwrt/staging/yousong.git] / Makefile
index 6cf4a4b1e0ebe4de6e82591d248ee9e5538ccca1..31042b2e09cf267ba65d24e44acd641ea821ea81 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -24,6 +24,8 @@ ifneq ($(OPENWRT_BUILD),1)
 
   override OPENWRT_BUILD=1
   export OPENWRT_BUILD
+  GREP_OPTIONS=
+  export GREP_OPTIONS
   include $(TOPDIR)/include/debug.mk
   include $(TOPDIR)/include/depends.mk
   include $(TOPDIR)/include/toplevel.mk
@@ -48,6 +50,8 @@ $(BUILD_DIR)/.prepared: Makefile
        @mkdir -p $$(dirname $@)
        @touch $@
 
+prepare: $(target/stamp-compile)
+
 clean: FORCE
        $(_SINGLE)$(SUBMAKE) target/linux/clean
        rm -rf $(BUILD_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)