another optimization
[openwrt/staging/yousong.git] / Makefile
index 4947cbf954e45c5f6b222eddd1fc706d36d4f41f..62a03387463aed51e47d3c46ccb9d19928d799df 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -21,10 +21,15 @@ SHELL:=/usr/bin/env bash
 export LC_ALL=C
 export LANG=C
 export TOPDIR=${shell pwd}
-include $(TOPDIR)/include/verbose.mk
 ifeq ($(KBUILD_VERBOSE),99)
   MAKE:=3>/dev/null $(MAKE)
 endif
+ifneq ($(shell tty -s <&3 || echo x),x)
+  IS_TTY=1
+  export IS_TTY
+endif
+
+include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)
@@ -38,11 +43,11 @@ endif
 export OPENWRTVERSION
 
 ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts Makefile),tmp/.pkginfo)
-  tmp/.pkginfo: tmpinfo-clean
+  tmp/.pkginfo: FORCE
 endif
 
 ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts Makefile),tmp/.targetinfo)
-  tmp/.targetinfo: tmpinfo-clean
+  tmp/.targetinfo: FORCE
 endif
 
 ifeq ($(FORCE),)