another optimization
[openwrt/staging/yousong.git] / Makefile
index d6b1b7d61854d1118c55e4c08fd52a94353012f1..62a03387463aed51e47d3c46ccb9d19928d799df 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -21,10 +21,15 @@ SHELL:=/usr/bin/env bash
 export LC_ALL=C
 export LANG=C
 export TOPDIR=${shell pwd}
-include $(TOPDIR)/include/verbose.mk
 ifeq ($(KBUILD_VERBOSE),99)
   MAKE:=3>/dev/null $(MAKE)
 endif
+ifneq ($(shell tty -s <&3 || echo x),x)
+  IS_TTY=1
+  export IS_TTY
+endif
+
+include $(TOPDIR)/include/verbose.mk
 
 OPENWRTVERSION:=$(RELEASE)
 ifneq ($(VERSION),)