imagebuilder: properly escape single quotes in device titles
[openwrt/staging/yousong.git] / Makefile
index 2b08d30ffe9da1c603ca14d546e92ea1876c2f92..a26eeee0a8b8727581ceae2be2a603702a0c2468 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -9,11 +9,12 @@
 TOPDIR:=${CURDIR}
 LC_ALL:=C
 LANG:=C
-export TOPDIR LC_ALL LANG
+TZ:=UTC
+export TOPDIR LC_ALL LANG TZ
 
 empty:=
 space:= $(empty) $(empty)
-$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
+$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the LEDE directory must not include any spaces))
 
 world:
 
@@ -38,11 +39,12 @@ else
   include tools/Makefile
   include toolchain/Makefile
 
-$(toolchain/stamp-install): $(tools/stamp-install)
-$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
+$(toolchain/stamp-compile): $(tools/stamp-compile)
+$(target/stamp-compile): $(toolchain/stamp-compile) $(tools/stamp-compile) $(BUILD_DIR)/.prepared
 $(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
 $(package/stamp-install): $(package/stamp-compile)
 $(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
+check: $(tools/stamp-check) $(toolchain/stamp-check) $(package/stamp-check)
 
 printdb:
        @true
@@ -50,10 +52,10 @@ printdb:
 prepare: $(target/stamp-compile)
 
 clean: FORCE
-       rm -rf $(BUILD_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)
+       rm -rf $(BUILD_DIR) $(STAGING_DIR) $(BIN_DIR) $(OUTPUT_DIR)/packages/$(ARCH_PACKAGES) $(BUILD_LOG_DIR) $(TOPDIR)/staging_dir/packages
 
 dirclean: clean
-       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST) $(BUILD_DIR_TOOLCHAIN)
+       rm -rf $(STAGING_DIR_HOST) $(STAGING_DIR_HOSTPKG) $(TOOLCHAIN_DIR) $(BUILD_DIR_BASE)/host $(BUILD_DIR_BASE)/hostpkg $(BUILD_DIR_TOOLCHAIN)
        rm -rf $(TMP_DIR)
 
 ifndef DUMP_TARGET_DB
@@ -82,23 +84,18 @@ prereq: $(target/stamp-prereq) tmp/.prereq_packages
                exit 1; \
        fi
 
-prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
-world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
-       $(_SINGLE)$(SUBMAKE) -r package/index
-
-# update all feeds, re-create index files, install symlinks
-package/symlinks:
-       $(SCRIPT_DIR)/feeds update -a
-       $(SCRIPT_DIR)/feeds install -a
+checksum: FORCE
+       $(call sha256sums,$(BIN_DIR))
 
-# re-create index files, install symlinks
-package/symlinks-install:
-       $(SCRIPT_DIR)/feeds update -i
-       $(SCRIPT_DIR)/feeds install -a
+diffconfig: FORCE
+       mkdir -p $(BIN_DIR)
+       $(SCRIPT_DIR)/diffconfig.sh > $(BIN_DIR)/config.seed
 
-# remove all symlinks, don't touch ./feeds
-package/symlinks-clean:
-       $(SCRIPT_DIR)/feeds uninstall -a
+prepare: .config $(tools/stamp-compile) $(toolchain/stamp-compile)
+world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
+       $(_SINGLE)$(SUBMAKE) -r package/index
+       $(_SINGLE)$(SUBMAKE) -r diffconfig
+       $(_SINGLE)$(SUBMAKE) -r checksum
 
 .PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean