brcm63xx: fix CVG834G compatible string
[openwrt/staging/yousong.git] / Makefile
index 2499304c6a149f2f65eceb102c76021d78426e60..c3e1ed77076feec19eeb171a780fa895a5dca6d8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -9,11 +9,12 @@
 TOPDIR:=${CURDIR}
 LC_ALL:=C
 LANG:=C
-export TOPDIR LC_ALL LANG
+TZ:=UTC
+export TOPDIR LC_ALL LANG TZ
 
 empty:=
 space:= $(empty) $(empty)
-$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
+$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the LEDE directory must not include any spaces))
 
 world:
 
@@ -50,10 +51,10 @@ printdb:
 prepare: $(target/stamp-compile)
 
 clean: FORCE
-       rm -rf $(BUILD_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)
+       rm -rf $(BUILD_DIR) $(STAGING_DIR) $(BIN_DIR) $(OUTPUT_DIR)/packages/$(ARCH_PACKAGES) $(BUILD_LOG_DIR)
 
 dirclean: clean
-       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST) $(BUILD_DIR_TOOLCHAIN)
+       rm -rf $(STAGING_DIR_HOST) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST) $(BUILD_DIR_TOOLCHAIN)
        rm -rf $(TMP_DIR)
 
 ifndef DUMP_TARGET_DB