libpcap: add optional netfilter support
[openwrt/staging/yousong.git] / include / autotools.mk
index c5ba748ab94c78ac326ffb3b3a60ae2f13fcb71b..7bd400ab36d052b39fcb76a66873c8673eb189a0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -51,9 +51,9 @@ endef
 
 # 1: build dir
 define patch_libtool
-       (cd $(1); \
+       @(cd $(1); \
                for lt in $$$$($$(STAGING_DIR_HOST)/bin/find . -name ltmain.sh); do \
-                       lt_version="$$$$($$(STAGING_DIR_HOST)/bin/sed -ne 's,^[[:space:]]*VERSION=\([0-9]\.[0-9]\+\).*,\1,p' $$$$lt)"; \
+                       lt_version="$$$$($$(STAGING_DIR_HOST)/bin/sed -ne 's,^[[:space:]]*VERSION="\?\([0-9]\.[0-9]\+\).*,\1,p' $$$$lt)"; \
                        case "$$$$lt_version" in \
                                1.5|2.2|2.4) echo "autotools.mk: Found libtool v$$$$lt_version - applying patch to $$$$lt"; \
                                        (cd $$$$(dirname $$$$lt) && $$(PATCH) -N -s -p1 < $$(TOPDIR)/tools/libtool/files/libtool-v$$$$lt_version.patch || true) ;; \
@@ -75,7 +75,7 @@ define autoreconf_target
   $(strip $(call autoreconf, \
     $(PKG_BUILD_DIR), $(PKG_REMOVE_FILES), \
     $(PKG_AUTOMAKE_PATHS), $(PKG_LIBTOOL_PATHS), \
-    $(STAGING_DIR)/host/share/aclocal $(STAGING_DIR)/usr/share/aclocal $(PKG_MACRO_PATHS)))
+    $(STAGING_DIR)/host/share/aclocal $(STAGING_DIR_HOSTPKG)/share/aclocal $(STAGING_DIR)/usr/share/aclocal $(PKG_MACRO_PATHS)))
 endef
 
 define patch_libtool_target
@@ -83,6 +83,23 @@ define patch_libtool_target
     $(PKG_BUILD_DIR)))
 endef
 
+define gettext_version_target
+       (cd $(PKG_BUILD_DIR) && \
+               GETTEXT_VERSION=$(shell $(STAGING_DIR_HOSTPKG)/bin/gettext -V | $(STAGING_DIR_HOST)/bin/sed -ne '1s/.*\([0-9]\.[0-9]\{2\}\.[0-9]\).*/\1/p' ) && \
+               $(STAGING_DIR_HOST)/bin/sed \
+                       -i $(PKG_BUILD_DIR)/configure.ac \
+                       -e "s/AM_GNU_GETTEXT_VERSION(.*)/AM_GNU_GETTEXT_VERSION(\[$$$$GETTEXT_VERSION\])/g" && \
+               $(STAGING_DIR_HOSTPKG)/bin/autopoint --force \
+       );
+endef
+
+ifneq ($(filter gettext-version,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += gettext_version_target
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += autoreconf_target
+ endif
+endif
+
 ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += patch_libtool_target
 endif