autotools.mk: like libintl, make all libtool fixup packages depend on the libiconv...
[openwrt/staging/yousong.git] / include / autotools.mk
index 2ab42df61fff471f4b1e905209bee0845b8361f5..9bb984da7c6211093e0e6eb034dfe14eac064ca7 100644 (file)
@@ -13,6 +13,17 @@ define libtool_remove_files
        find $(1) -name '*.la' | $(XARGS) rm -f;
 endef
 
+
+AM_TOOL_PATHS:= \
+       AUTOM4TE=$(STAGING_DIR_HOST)/bin/autom4te \
+       AUTOCONF=$(STAGING_DIR_HOST)/bin/autoconf \
+       AUTOMAKE=$(STAGING_DIR_HOST)/bin/automake \
+       ACLOCAL=$(STAGING_DIR_HOST)/bin/aclocal \
+       AUTOHEADER=$(STAGING_DIR_HOST)/bin/autoheader \
+       LIBTOOLIZE=$(STAGING_DIR_HOST)/bin/libtoolize \
+       M4=$(STAGING_DIR_HOST)/bin/m4 \
+       AUTOPOINT=true
+
 # 1: build dir
 # 2: remove files
 # 3: automake paths
@@ -22,15 +33,14 @@ define autoreconf
        (cd $(1); \
                $(patsubst %,rm -f %;,$(2)) \
                $(foreach p,$(3), \
-                       if [ -x $(p)/autogen.sh ]; then \
-                               $(p)/autogen.sh || true; \
-                       elif [ -f $(p)/configure.ac ] || [ -f $(p)/configure.in ]; then \
+                       if [ -f $(p)/configure.ac ] || [ -f $(p)/configure.in ]; then \
                                [ -f $(p)/aclocal.m4 ] && [ ! -f $(p)/acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
                                [ -d $(p)/autom4te.cache ] && rm -rf autom4te.cache; \
-                               $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                               touch NEWS AUTHORS COPYING ChangeLog; \
+                               $(AM_TOOL_PATHS) $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
                                        -B $(STAGING_DIR_HOST)/share/aclocal \
                                        $(patsubst %,-B %,$(5)) \
-                                       $(patsubst %,-I %,$(4)) $(4) || true; \
+                                       $(patsubst %,-I %,$(4)) -I m4 $(4) || true; \
                        fi; \
                ) \
        );
@@ -51,14 +61,14 @@ define autoreconf_target
 endef
 
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
+  PKG_BUILD_DEPENDS += libtool libintl libiconv
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif
 endif
 
 ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
+  PKG_BUILD_DEPENDS += libtool libintl libiconv
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif
@@ -83,14 +93,12 @@ define autoreconf_host
 endef
 
 ifneq ($(filter libtool,$(HOST_FIXUP)),)
-  HOST_BUILD_DEPENDS += libtool
  ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
   Hooks/HostConfigure/Pre += autoreconf_host
  endif
 endif
 
 ifneq ($(filter libtool-ucxx,$(HOST_FIXUP)),)
-  HOST_BUILD_DEPENDS += libtool
  ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
   Hooks/HostConfigure/Pre += autoreconf_host
  endif