build: copy contents of 'src' folder to build dirs (if present)
[openwrt/staging/yousong.git] / include / host-build.mk
index 72b32597d4d230df7fe9e42ebd505de131c733ac..56e0e4e4136e5a43eacf1bf04b3bd967fbcb5f78 100644 (file)
@@ -43,6 +43,7 @@ Host/Patch:=$(Host/Patch/Default)
 ifneq ($(strip $(HOST_UNPACK)),)
   define Host/Prepare/Default
        $(HOST_UNPACK)
+       [ ! -d ./src/ ] || $(CP) ./src/* $(HOST_BUILD_DIR)
        $(Host/Patch)
   endef
 endif