build: make Host/Install/Default use Host/Compile/Default with an extra argument
[openwrt/staging/yousong.git] / include / host-build.mk
index d96cc94fa3c6d12f6eb2cf5c95579497a314e8d5..ffb68468f9972a379cee39503d27433ddf2dc02a 100644 (file)
@@ -108,7 +108,7 @@ define Host/Compile
 endef
 
 define Host/Install/Default
-       $(_SINGLE)$(MAKE) -C $(HOST_BUILD_DIR) install
+       $(call Host/Compile/Default,install)
 endef
 
 define Host/Install
@@ -182,6 +182,7 @@ ifndef DUMP
   $(_host_target)host-prepare: $(HOST_STAMP_PREPARED)
   $(_host_target)host-configure: $(HOST_STAMP_CONFIGURED)
   $(_host_target)host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED)
+  host-install: host-compile
 
   host-clean-build: FORCE
        rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_BUILT)