scripts/ubinize-image.sh: add support for adding custom partitions
[openwrt/staging/yousong.git] / include / image-commands.mk
index 00cb3410e95631a7808b8a624d0ee32f0445907c..40a9619c31c4d3015d9d001b140081d27f5aea24 100644 (file)
@@ -114,6 +114,7 @@ define Build/append-ubi
        sh $(TOPDIR)/scripts/ubinize-image.sh \
                $(if $(UBOOTENV_IN_UBI),--uboot-env) \
                $(if $(KERNEL_IN_UBI),--kernel $(IMAGE_KERNEL)) \
+               $(foreach part,$(UBINIZE_PARTS),--part $(part)) \
                $(IMAGE_ROOTFS) \
                $@.tmp \
                -p $(BLOCKSIZE) -m $(PAGESIZE) \