image: add support for overriding kernel/rootfs images in sysupgrade-tar template
[openwrt/staging/yousong.git] / include / image-commands.mk
index 8cf54bbaa16795e389863c7001d207a5ae53968f..f95a68dab14ac529b967a6f1d7d48d5d21916c56 100644 (file)
@@ -151,7 +151,7 @@ endef
 define Build/sysupgrade-tar
        sh $(TOPDIR)/scripts/sysupgrade-tar.sh \
                --board $(if $(BOARD_NAME),$(BOARD_NAME),$(DEVICE_NAME)) \
-               --kernel $(word 1,$^) \
-               --rootfs $(word 2,$^) \
+               --kernel $(call param_get_default,kernel,$(1),$(word 1,$^)) \
+               --rootfs $(call param_get_default,rootfs,$(1),$(word 2,$^)) \
                $@
 endef