kernel: update to kernel version 2.6.32.32
[openwrt/staging/yousong.git] / include / kernel-version.mk
index eaac886ebb19920b56167972af6bb5dd6d8fcb44..f67277dedaafe780b6138d6a713b92afd9b912e7 100644 (file)
@@ -1,15 +1,35 @@
 # Use the default kernel version if the Makefile doesn't override it
 
-ifeq ($(LINUX_VERSION),)
-  ifeq ($(KERNEL),2.4)
-    LINUX_VERSION:=2.4.34
-    LINUX_RELEASE:=1
-    LINUX_KERNEL_MD5SUM:=f59665540a7f3351ea416a0dad104b55
-  else
-    LINUX_VERSION:=2.6.21.5
-    LINUX_RELEASE:=1
-    LINUX_KERNEL_MD5SUM:=2e9a302b5d514b231640227d6a2ab7bf
-  endif
-endif
-KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
+LINUX_RELEASE?=1
+
+ifeq ($(LINUX_VERSION),2.6.30.10)
+  LINUX_KERNEL_MD5SUM:=eb6be465f914275967a5602cb33662f5
+endif
+ifeq ($(LINUX_VERSION),2.6.31.14)
+  LINUX_KERNEL_MD5SUM:=3e7feb224197d8e174a90dd3759979fd
+endif
+ifeq ($(LINUX_VERSION),2.6.32.32)
+  LINUX_KERNEL_MD5SUM:=25a3ba004aaaa409c24dfb2cc268d03e
+endif
+ifeq ($(LINUX_VERSION),2.6.34.7)
+  LINUX_KERNEL_MD5SUM:=8964e26120e84844998a673464a980ea
+endif
+ifeq ($(LINUX_VERSION),2.6.35.11)
+  LINUX_KERNEL_MD5SUM:=4c9ee33801f5ad0f4d5e615fac66d535
+endif
+ifeq ($(LINUX_VERSION),2.6.36.4)
+  LINUX_KERNEL_MD5SUM:=c05dd941d0e249695e9f72568888e1bf
+endif
+ifeq ($(LINUX_VERSION),2.6.37.1)
+  LINUX_KERNEL_MD5SUM:=07d3b1868a67c1a7ddcf1d54444cb5d1
+endif
+
+# disable the md5sum check for unknown kernel versions
+LINUX_KERNEL_MD5SUM?=x
+
+split_version=$(subst ., ,$(1))
+merge_version=$(subst $(space),.,$(1))
+KERNEL_BASE=$(firstword $(subst -, ,$(LINUX_VERSION)))
+KERNEL=$(call merge_version,$(wordlist 1,2,$(call split_version,$(KERNEL_BASE))))
+KERNEL_PATCHVER=$(call merge_version,$(wordlist 1,3,$(call split_version,$(KERNEL_BASE))))