uhttpd: Moved uhttpd to Network|Web Servers/Proxies submenu, just like all the other...
[openwrt/staging/yousong.git] / include / package-bin.mk
index 6ee7aed6217087df154eff60a318fe36c2688512..96c1aeffcfb0b59c1d4811b75288de3a1e28df1d 100644 (file)
@@ -7,6 +7,7 @@
 
 ifeq ($(DUMP),)
   define BuildTarget/bin
+    ifeq ($(if $(VARIANT),$(BUILD_VARIANT)),$(VARIANT))
     ifdef Package/$(1)/install
       ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
         compile: install-bin-$(1)
@@ -16,6 +17,7 @@ ifeq ($(DUMP),)
                @echo "WARNING: skipping $(1) -- package not selected"
       endif
     endif
+    endif
 
     install-bin-$(1): $(STAMP_BUILT)
          rm -rf $(BIN_DIR)/$(1)