add sitefile entries for ac_cv_func_creal,cimag - the functions are there, but config...
[openwrt/staging/yousong.git] / include / package-defaults.mk
index 117497d5ded5402dda69d490360bc66d0636d4c5..1d29119d81fab0aba0a8f3eab81c430ae99000af 100644 (file)
@@ -23,10 +23,15 @@ define Package/Default
   else
     VERSION:=$(PKG_RELEASE)
   endif
-  ifneq ($(CONFIG_TARGET_adm5120),y)
-    PKGARCH:=$(BOARD)
+  ifneq ($(PKG_FLAGS),)
+    PKGFLAGS:=$(PKG_FLAGS)
+  else
+    PKGFLAGS:=
+  endif
+  ifneq ($(ARCH_PACKAGES),)
+    PKGARCH:=$(ARCH_PACKAGES)
   else
-    PKGARCH:=$(BOARD)_$(ARCH)
+    PKGARCH:=$(BOARD)
   endif
   PRIORITY:=optional
   DEFAULT:=
@@ -43,7 +48,7 @@ endef
 Build/Patch:=$(Build/Patch/Default)
 ifneq ($(strip $(PKG_UNPACK)),)
   define Build/Prepare/Default
-       $(PKG_UNPACK)
+       $(SH_FUNC) $(PKG_UNPACK)
        $(Build/Patch)
   endef
 endif