autotools.mk: add a (dummy) libintl build dependency to any package using the libtool...
[openwrt/staging/yousong.git] / include / package.mk
index 712b793d0d63258853f88794d3294ddd0c2556e5..580774134c916c4aff3fad0040a90881c4fa0aa6 100644 (file)
@@ -75,10 +75,6 @@ define Download/default
   MD5SUM:=$(PKG_MD5SUM)
 endef
 
-define sep
-
-endef
-
 define Build/Exports/Default
   $(1) : export ACLOCAL_INCLUDE=$$(foreach p,$$(wildcard $$(STAGING_DIR)/usr/share/aclocal $$(STAGING_DIR)/usr/share/aclocal-* $$(STAGING_DIR)/host/share/aclocal $$(STAGING_DIR)/host/share/aclocal-*),-I $$(p))
   $(1) : export STAGING_PREFIX=$$(STAGING_DIR)/usr
@@ -132,8 +128,9 @@ define Build/DefaultTargets
                $(call $(hook),$(TMP_DIR)/stage-$(PKG_NAME),$(TMP_DIR)/stage-$(PKG_NAME)/host)$(sep)\
        )
        if [ -d $(TMP_DIR)/stage-$(PKG_NAME) ]; then \
+               (cd $(TMP_DIR)/stage-$(PKG_NAME); find ./ > $(TMP_DIR)/stage-$(PKG_NAME).files); \
                $(call locked, \
-                       (cd $(TMP_DIR)/stage-$(PKG_NAME); find ./ > $(STAGING_DIR)/packages/$(STAGING_FILES_LIST)); \
+                       mv $(TMP_DIR)/stage-$(PKG_NAME).files $(STAGING_DIR)/packages/$(STAGING_FILES_LIST) && \
                        $(CP) $(TMP_DIR)/stage-$(PKG_NAME)/* $(STAGING_DIR)/; \
                ,staging-dir); \
        fi