uboot-imx6: switch to u-boot.mk
[openwrt/staging/yousong.git] / include / prereq-build.mk
index 0e145c939b03295dd8ea02768ba89fb000750e97..af4e8b5e14640af95a136c1abcf36c653f7c2214 100644 (file)
@@ -24,6 +24,10 @@ $(eval $(call TestHostCommand,case-sensitive-fs, \
        rm -f $(TMP_DIR)/test.*; touch $(TMP_DIR)/test.fs; \
                test ! -f $(TMP_DIR)/test.FS))
 
+$(eval $(call TestHostCommand,proper-umask, \
+       Please build with umask 022 - other values produce broken packages, \
+       umask | grep -xE 00[012][012]))
+
 $(eval $(call SetupHostCommand,gcc, \
        Please install the GNU C Compiler (gcc), \
        $(CC) --version | grep gcc, \
@@ -71,11 +75,6 @@ $(eval $(call TestHostCommand,zlib, \
        echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
                gcc -include zlib.h -x c -o $(TMP_DIR)/a.out - $(zlib_link_flags)))
 
-$(eval $(call TestHostCommand,libssl, \
-       Please install the openssl library (with development headers), \
-       echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
-               gcc $(HOST_CFLAGS) -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl $(HOST_LDFLAGS)))
-
 $(eval $(call TestHostCommand,perl-thread-queue, \
        Please install the Perl Thread::Queue module, \
        perl -MThread::Queue -e 1))
@@ -102,8 +101,8 @@ $(eval $(call SetupHostCommand,diff,Please install diffutils, \
        diff --version 2>&1 | grep diff))
 
 $(eval $(call SetupHostCommand,cp,Please install GNU fileutils, \
-       gcp --help, \
-       cp --help))
+       gcp --help 2>&1 | grep 'Copy SOURCE', \
+       cp --help 2>&1 | grep 'Copy SOURCE'))
 
 $(eval $(call SetupHostCommand,seq,, \
        gseq --version, \
@@ -128,11 +127,6 @@ $(eval $(call SetupHostCommand,stat,Cannot find a file stat utility, \
        gstat -c%s $(TMP_DIR)/.host.mk, \
        stat -c%s $(TMP_DIR)/.host.mk))
 
-$(eval $(call SetupHostCommand,md5sum,, \
-       gmd5sum /dev/null | grep d41d8cd98f00b204e9800998ecf8427e, \
-       md5sum /dev/null | grep d41d8cd98f00b204e9800998ecf8427e, \
-       $(SCRIPT_DIR)/md5sum /dev/null | grep d41d8cd98f00b204e9800998ecf8427e))
-
 $(eval $(call SetupHostCommand,unzip,Please install 'unzip', \
        unzip 2>&1 | grep zipfile, \
        unzip))
@@ -151,18 +145,17 @@ $(eval $(call SetupHostCommand,python,Please install Python 2.x, \
        python2 -V 2>&1 | grep Python, \
        python -V 2>&1 | grep Python))
 
-$(eval $(call SetupHostCommand,svn,Please install the Subversion client, \
-       svn --version | grep Subversion))
-
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
        git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version 2>&1 | grep file))
 
-$(eval $(call SetupHostCommand,openssl,Please install the 'openssl' utility, \
-       openssl version | grep '\(OpenSSL\|LibreSSL\)'))
+$(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
+       mkdir -p $(dir $@)
+       $(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<
 
+prereq: $(STAGING_DIR_HOST)/bin/mkhash
 
 # Install ldconfig stub
 $(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \