package/madwifi: fix r23829 commit
[openwrt/staging/yousong.git] / include / quilt.mk
index 6c4839ba4ac324efc5f226e03c9bf548c6fb8572..9691dc3276c68dc8664ac38bd73d7c6afff1e628 100644 (file)
@@ -40,11 +40,12 @@ endef
 
 define PatchDir/Default
        @if [ -d "$(2)" -a "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
+               export PATCH="$(PATCH)"; \
                if [ -s "$(2)/series" ]; then \
                        $(call filter_series,$(2)/series) | xargs -n1 \
-                               $(PATCH) "$(1)" "$(2)"; \
+                               $(KPATCH) "$(1)" "$(2)"; \
                else \
-                       $(PATCH) "$(1)" "$(2)"; \
+                       $(KPATCH) "$(1)" "$(2)"; \
                fi; \
        fi
 endef