build: opkg: enable presence of uci
[openwrt/staging/yousong.git] / include / rootfs.mk
index bd9af6ae4906b703c3ad666ba7e9312641ad728f..46ccce49eb5c62b1b9d8401e573467ad250d5e44 100644 (file)
@@ -37,6 +37,9 @@ endif
 opkg = \
   IPKG_NO_SCRIPT=1 \
   IPKG_INSTROOT=$(1) \
+  UCI=$(STAGING_DIR_HOST)/sbin/uci \
+  UCI_CONFDIR=$(1)/etc/config \
+  UCI_SAVEDIR=$(1)/tmp/.uci \
   TMPDIR=$(1)/tmp \
   $(STAGING_DIR_HOST)/bin/opkg \
        --offline-root $(1) \
@@ -61,9 +64,14 @@ define prepare_rootfs
        fi
        @mkdir -p $(1)/etc/rc.d
        @( \
-               cd $(1); \
+               cd $(1); shell=$$(which bash); \
+               mkdir -p $(1)/tmp/.uci/;  \
                for script in ./usr/lib/opkg/info/*.postinst; do \
-                       IPKG_INSTROOT=$(1) $$(which bash) $$script; \
+                       IPKG_INSTROOT=$(1) \
+                       UCI=$(STAGING_DIR_HOST)/sbin/uci \
+                       UCI_CONFDIR=$(1)/etc/config \
+                       UCI_SAVEDIR=$(1)/tmp/.uci \
+                               $$shell $$script; \
                        ret=$$?; \
                        if [ $$ret -ne 0 ]; then \
                                echo "postinst script $$script has failed with exit code $$ret" >&2; \
@@ -72,7 +80,11 @@ define prepare_rootfs
                done; \
                for script in ./etc/init.d/*; do \
                        grep '#!/bin/sh /etc/rc.common' $$script >/dev/null || continue; \
-                       IPKG_INSTROOT=$(1) $$(which bash) ./etc/rc.common $$script enable; \
+                       IPKG_INSTROOT=$(1) \
+                       UCI=$(STAGING_DIR_HOST)/sbin/uci \
+                       UCI_CONFDIR=$(1)/etc/config \
+                       UCI_SAVEDIR=$(1)/tmp/.uci \
+                               $$shell ./etc/rc.common $$script enable; \
                done || true \
        )
        $(if $(SOURCE_DATE_EPOCH),sed -i "s/Installed-Time: .*/Installed-Time: $(SOURCE_DATE_EPOCH)/" $(1)/usr/lib/opkg/status)